Just installed Mint FB 9 on a Compaq R4000. Using a TrendNET cardbus wifi card which has been working beautifully with Linux for about 3.5 years. (Atheros chipset). Ethernet is Realtek.

The problem I am encountering is thus:

Everything seems to load fine, wifi connects no problem. Connection is never dropped. Strong signal all of the time. Unfortunately no 'net services are usable. When I attempt to log in to my router I get the login popup (Linksys WRT54) and the basic settings screen only partially loads. No web sites will load at all. Ping results are positive both on the local network and to gmail.com. For a short period, some data was getting through. Soon reverted to non-working mode.

I also tried connecting to the router via ethernet and experienced exactly the same problem.

lspci showed the ethernet using 8139cp and 8139too modules, wifi using ath5k.

Tried 'modprobe -r ' on 8139cp and 8139too (at the same time so only ath5k was still loaded) with no success.


p.s. should mention that this comp was working just fine running FB 8, and the other comp in the house which is still running FB 8 have no network issues whatsoever.