Find the answer to your Linux question:
Results 1 to 4 of 4
I'm trying to set up a Debian Woody with a 2.4.18 Kernel. I haven't been able to get it to connect to the network in any meaningful way. I've cobbled ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Location
    Waterloo, Ontario, Canada
    Posts
    10

    Very limited network.


    I'm trying to set up a Debian Woody with a 2.4.18 Kernel. I haven't been able to get it to connect to the network in any meaningful way. I've cobbled a basic method together, which has been endorsed in other posts (and the network cable is plugged in, and the lights on the card blink, so something's there):

    1)Load the module, this now gets done by putting it in /etc/modules. This makes eth0 a valid device.
    2)My /etc/network/interfaces looks like
    Code:
    auto lo
    ifcase lo inet loopback
    
    iface eth0 inet static
    address 10.0.0.2
    netmask 255.0.0.0
    gateway 10.0.0.1
    Pinging my gateway works, but other computers I know are on the network (a different subnet I think, last two numbers are different, instead of just one) don't get any response, ping just waits, and then when I ctrl-c it, it says 100% packet loss. However I can ping in from other computers and subnets just fine.

    3)If I try "mii-tool" then I get
    Code:
    SIOCGMIIPHY on 'eth0' failed: Bad address
    no MII interfaces found
    I tried this, it didn't work, and I was told that it probably had nothing to do with the problem:
    4)I add the gateway server that I was given, with "route add default gw [gateway ip given to me]. If I just type "route", the gateway entry takes forever to appear. It also doesn't change the results of pinging any of the addresses I know are on the rest of the network.

    Also, I recently discovered in the syslog (this is a relatively recent result of one of my tries I think, I didn't see it right away):
    Code:
    eth0:network connection up using port A
         speed: 100
         autonegotiation: yes
         duplex mode: half
         flow control: none
         irq moderation: disabled
         scatter-gather: enabled
         tx-checksum: enabled
         rx-checksum: enabled
    The duplex mode caught my eye in particular, as all the other computers on the network are full duplex. However, by my understanding, this is what mii-tool is for, which I can't use.

    I've been banging my head against this for a couple weeks now. I think I'm being punished for years of Windows (which I have repented).

  2. #2
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    158
    Hi,

    Might be the router settings that is missing/incorrect...

    please post the result of "route -n"...

    Also are you trying to ping the ipaddresses or the names of the other machines?

    Regards

    Jonas
    --
    in Linux Computing we Trust

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Location
    Waterloo, Ontario, Canada
    Posts
    10
    Thanks for responding.

    Here's my routing table:
    I've changed my IP, gateway IP etc. I'll represent them with:
    IP: 100.100.100.100
    gateway: 100.100.100.1
    Code:
    lt-vi:~#route -n
    kernel IP Routing Table
    Destination       Gateway        Genmask       Flags  Metric  Ref  Use Iface
    100.100.100.0     0.0.0.0        255.255.255.0   U       0     0    0  eth0
    0.0.0.0           100.100.100.1  0.0.0.0         UG      0     0    0  eth0
    I'm using the actual IP addresses to ping. We've got two other machines in the room. One on the subnet 100 with me, and one on another (one has IP 100.100.100.64 and the other, IP 100.100.60.61 gateway 100.100.60.1). Nobody can ping anything on the 60 subnet (times out on Windows, sits there until ctrl-c with Debian), and the 60-subnet machine can't ping it's own gateway (but can still access the internet). The 60-subnet machine can ping the 100 subnet.

    I apologize if this is very confusing. I recently discovered that telnetting anyone will make the machine freeze solid. No mouse, no keyboard, no pinging from outside. If I'm running telnet from the console, instead of KDM, I get an error message when I crash telnet which I haven't been able to make heads or tails of:
    Code:
    sWarning: kfree_skb passed an skb still on a list (from e092f1bb)
    invalid operand:0000
    CPU 0
    EIP ... Not Tainted
    ...
    Process Telnet (pid: 514, stackpage ...)
    Stack [96 bytes here, in 4 byte hex chunks]
    Call Trace [208 bytes in 4 byte hex chunks]
    Code: [20 bytes in single byte hex chunks]
    <0>Kernel panic&#58; Aiee, killing interrupt handler
    In interrupt handler - not syncing
    Where ... represents mixtures of hex strings and character labels, which I can't understand.

    My little assembly experience tells me that interrupt handlers are important to keep around. Which might explain the irreparability of the freeze, but I don't know why it's happening. Thank you very much for taking time with this.

  4. #4
    Just Joined!
    Join Date
    Nov 2004
    Location
    Waterloo, Ontario, Canada
    Posts
    10
    I've solved the freezing problem, it turns out I just had a glitchy installation. I was griping to a friend about this and my mouse problem. And he told me just to burn it all. So I can't freeze it solid anymore, but I still can't get on the network.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •