Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I am trying to get a small cluster running on some HP 4200 work stations. My version of the clustering software requires the 2.4.27 kernel. It requires that I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    24

    Networking fails after kernel change


    Hi, I am trying to get a small cluster running on some HP 4200 work stations. My version of the clustering software requires the 2.4.27 kernel. It requires that I use the vanilla kernel (ie the official from kernel.org). I downloaded the source for my kernel version and compiled it, ( as directed by the tldp.org how to ) with all network services enabled, and with support for my NIC built in. However I can not connect to any external device after the update.

    Things I know

    the NIC is configured with a static IP and it comes up just fine with the specified IP, gateway etc....

    I can ping and ssh the loop back device successfully.

    I cannot ping anything external to the machine - destination host unreachable

    working machines on the same lan cannot ping its network card

    Machine configuration

    RH9 ( starts as the 2.4.20-8 kernel )

    Broadcom 57** NIC ( configured with either the tg3 driver or bcm5700.o )
    the NIC seems to be working.

    TIA for any help.

    ytinrete

  2. #2
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    158
    Hi,

    Can you post the result of the following;

    ifconfig -a
    lsmod
    route -n

    Thanks

    Jonas
    --
    in Linux Computing we Trust

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    24
    here's the info you asked for

    ifconfig
    192.168.1.12 Bcast 192.168.1.255 Mask 255.255.255.0
    UP BROADCAST MULTICAST MTU:1500 Metric:1

    lo
    127.0.0.1 Mask 255.0.0.0
    UP LOOPBACK RUNNING MTU:16436: Metric:1

    ismod command not found

    route

    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 eth0
    0.0.0.0 192.168.1.10 0.0.0.0 UG 0 0 0 eth0


    these are running through a router ( SuSE 9.1 ) the router works well as I can talk out before the kernel updates, and bittorent screams through it

    thanks
    ytinrete

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    If you have identical machines, just compare the outputs of the commands that you posted with the same commands on a working machine. You may have made a typo somewhere?

    Also...the command is not 'ismod'. It is 'lsmod' as in "EL-ES-MOD".
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    24
    lmod returned no values. thnx for the correction

    I integrated the TG3 driver into the kernel, but I should see some modules loaded as not every thing was so lucky. Strange

    as for the compare and contrast.

    I have tried to do what you have suggested to no avail. In fact the network settings before and after the kernel update are identical

    What is more an identical machine running a RH9 standered kernel (2.4.20- using similer settings (except the IP) can connect just fine.

    thnx
    ytinrete

  7. #6
    Just Joined!
    Join Date
    Nov 2004
    Posts
    24
    Thnx to those who tried to help. However I have fixed it. I switched to Slackware

    It's kinda like, how NASA spent 10 years and millions of dollars developing a pen that can write in zero G, while the Russians used a pencil

    ytinrete

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •