Find the answer to your Linux question:
Results 1 to 3 of 3
Hi guys, I hope someone can shed some light to my problem. I recently setup LVS to act as a load balancer for my web servers. Basically everything worked fine, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Location
    Malaysia
    Posts
    15

    IPVS - Load Balancing


    Hi guys,
    I hope someone can shed some light to my problem.

    I recently setup LVS to act as a load balancer for my web servers.

    Basically everything worked fine, until i began to test the performance of the load balancer.

    I basically have 3 servers in total.
    - 1 load balancer (LVS director)
    - 2 apache web servers (real server)
    The load balancer has been configured to route all port 80 connections to the 2 apache web servers.

    I ran apache bench with the setting of 1000 concurrent connections of a total of 2000 request to the load balancer and saw that 900 connections failed.
    Eg. ab -c 1000 -n 2000 xxxxxxxx

    The result was like this:
    Concurrency Level: 1000
    Time taken for tests: 9.548 seconds
    Complete requests: 2000
    Failed requests: 924
    (Connect: 0, Receive: 0, Length: 924, Exceptions: 0)
    Write errors: 0
    Total transferred: 101895760 bytes
    HTML transferred: 101322760 bytes
    Requests per second: 209.47 [#/sec] (mean)
    Time per request: 4774.038 [ms] (mean)
    Time per request: 4.774 [ms] (mean, across all concurrent requests)
    Transfer rate: 10421.74 [Kbytes/sec] received


    I ran the same test directly to the realserver (web server) and all the http connection was successful. This actually proved that the director could not forward all the connections to the realservers. Any idea what caused this?

    I've modified the ulimit, but, still fail to forward completely to the realservers.


    Any insight will be greatly appreciated. Thank you.

  2. #2
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,356
    Transfer rate: 10421.74 [Kbytes/sec] received
    Are you using a 100MBit/s NIC or a 1GBit/s NIC in 100MBit/s mode?
    You must always face the curtain with a bow.

  3. #3
    Just Joined!
    Join Date
    May 2011
    Location
    Malaysia
    Posts
    15
    It's a 100Mbps NIC.


    ethtool eth1
    Settings for eth1:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbag
    Wake-on: g
    Current message level: 0x00000001 (1)
    Link detected: yes

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •