Find the answer to your Linux question:
Results 1 to 5 of 5
OK... now that I have Samba setup as a PDC I am running into a curious issue... one of the users on my network creates a file, copies something to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    44

    Groups and user controls...


    OK... now that I have Samba setup as a PDC I am running into a curious issue... one of the users on my network creates a file, copies something to the network or makes a new file there.

    Afterward, another user (who I have assigned to the same group) wants to rename the file, or make modifications... but unfortunately can't because every file that is created has read/modify rights for only the creator, but the group is always set to just read only.

    What gives? I mean, I set an entire folder to read/modify for the group, and put one folder there, and it doesn't inherit the permissions from the folder. It is driving me nuts! Each and every time I copy something to the folder I have to have that user go in and modify the permissions and it is just a pain.

    So... how do I change it so that the group is able to make changes? I mean I'm not looking for everyone... but at the very least the group.

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    You will have to change the umask. I think it is in the smb.conf. Change it from 022 to 002, and that should do the trick.

    Best,

    Samuel
    I respectfully decline the invitation to join your delusion.

  3. #3
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    158
    Hi,

    and it doesn't inherit the permissions from the folder
    No it doesn't!

    If you want that to happen you need to put the sticky bit on the group for that directory. i.e. chmod g+s <your dir>

    As explained before you also need to make sure the file is created with the right rights = change the umask... (ls -l should give -rw-rw--- (at least)

    Good luck!

    //jonas
    --
    in Linux Computing we Trust

  4. #4
    Just Joined!
    Join Date
    Sep 2004
    Posts
    44
    Now at one point I applied "sticky"... no idea what it meant, still not sure (haven't looked into it yet), but newly created files within folders still proceeded to do the same thing, so I just wrote it off...

  5. #5
    Just Joined!
    Join Date
    Jun 2004
    Location
    London, UK
    Posts
    53
    Two very usefull smb.conf options are:
    Code:
    directory mask = 0775
    create mask = 0774
    This will make a objects writeable to both user and group.

    Also check the secionds "inherit permissions", "force create mask", "force directory mask", "force user" and "force group" in the man-page for smb.conf.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •