Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all Well i was gloating yesterday cause I got things working finally but it would appear I have already managed to screw things up again! hey well those are ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    19

    :-( localhost not found when starting apache2


    Hello all

    Well i was gloating yesterday cause I got things working finally but it would appear I have already managed to screw things up again!

    hey well those are the benefits of being a newbie i guess...

    anyway, what happens was the my linux webserver was working fine yesterday serving up my php page, i could even access it from work! so i was all happy of course...

    Then i went home and decided to upgrade my php from 4.3.8 to version 5. after a little trouble having to select and deselecting various packages because of compatibiility issues etc... i managed to get everything installed ok. Then i went on to install some more apache2 mods.. And then i rebooted the machine...

    so far so good...

    When things were back up and running however i was no longer able to access my site, even locally..

    i checked whether apache was running, which is wasnt so i started it with apachectl restart

    it said ok but still nothing.. so i did an apachectl extendedstatus which said that it could start cause it cant find localhost..??

    i've checked my /etc/host file which just says

    127.0.0.1 localhost
    10.0.0.1 myserver

    the share on which the documents are located still works ok, httpd2.conf still looks the same and still has the same DOCUMENTROOT set, so i'm a little flabbergasted as to what has happened??

    anyone got any suggestions?

    Thanks!


  2. #2
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    First off, there is no need to reboot a linux machine for a php or apache upgrade. Just not necessary, I wouldn't do it. It is hard on the physical hardware. That is why so many drives/fans/cpus fail on startup relative to during a long run.

    Second, post the exact output as seen in the error_log. This is usually /var/log/error_log, but I can't be sure. Just saying it failed with an error that has three syllables, sounds like elbow, and is a mineral doesn't really help us help you much.

    Best,

    Samuel
    I respectfully decline the invitation to join your delusion.

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    19
    Hi there

    thanks for the feedback! yes i know that rebooting isn't required really, old windows habits i fear! Although I'm still not quite sure how that works if you update something, I guess you need to restart the service every time you update something instead?

    Anyway, I've sorted the problem it seem. After spending a whole evening checked all my samba fstab httpd2 and php settings it looked like something wasnt working with my php upgrade as it was still saying version 4.3.8 when i did php -i.

    Also apachectl start didnt work but if i did httpd start it did...?? which was a bit strange as i though they should achieve the same goal but hey...

    Decided to uninstall all php related software and reinstall only the php5 modules. this seemed to fix the php issue as the website now was working again..

    problem then was that i could only see it inside my home network but not from the internet...

    so i checked my hosts and hostname setting and anything else i could think off, even reboot the router but still no go...
    so i switched off the bloody thing and decided to leave it..

    Went to work this morning and it's working again!!?

    Now I'm completely confused, seems like it's fixed itself overnight..?? Let's see now if it'll keep working...

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •