Find the answer to your Linux question:
Results 1 to 5 of 5
hello dear professionals; i am learning linux so my questions may be simple but i appreciate if you help me, i opened httpd apache on my linux machine (ntsysv opened ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2011
    Posts
    3

    accessing linux machine running apache


    hello dear professionals;

    i am learning linux so my questions may be simple but i appreciate if you help me,

    i opened httpd apache on my linux machine (ntsysv opened httpd service) and when i write localhost on my browser it runs, but when i try to access from another machine (write ip number on browser) running windows on network it does not show the apache running page,
    how do i make it work?

    when i install on windows i can see running from another machine,

    thanks in advance for your answers,

    hayrullah
    istanbul-turkey

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    What distro of Linux are you using?

    Perhaps there is a firewall running on the Linux machine? Try temporarily disabling it - the command depends upon your Linux distro but is usually something like:
    Code:
    /etc/init.d/iptables stop
    Then try to access the webpage again.

    Also, make sure your Windows PC can "see" your Linux PC - try a ping from the cmd window to test that.

    Check the web server logs, too, in case anything is being reported there. Again, depends upon distro, but try this dir: /var/log/httpd/

  3. #3
    Just Joined!
    Join Date
    Jun 2011
    Posts
    3

    my linux is oracle linux 6.0

    i will try your suggestionsm and after i will let you know if it works,

    ping between machines are successfull

  4. #4
    Just Joined!
    Join Date
    Jun 2011
    Posts
    3

    Thumbs up it worked!

    thank you my friend after i run the command it worked,

  5. #5
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    good. now you'll either have to disable the firewall upon reboot, or add a rule allowing port 80 out of your firewall.

    to disable iptables, it depends on your distro (tired of hearing that yet), but you can try:
    Code:
    chkconfig iptables off
    if the command returns nothing, it worked. otherwise, tell use your distro and we'll help you turn it off.

    The more security-conscious way is to add the iptables rule to your firewall - let us know if you want to do that - a bit more involved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •