Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I need to connect to my office which has a RAS callback server. I managed (in spite of my inexperience) to d/l and recompile pppd, so that it would ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2010
    Posts
    23

    "NO CARRIER" on callback using kppp


    Hi,
    I need to connect to my office which has a RAS callback server.
    I managed (in spite of my inexperience) to d/l and recompile pppd, so that it would support CBCP (MS callback).
    I now have gotten to the stage where kppp has successfully logged me in to RAS, and hung up to wait for the return call.
    The problem is that as soon as the phone rings, kppp says "NO CARRIER" and disconnects me:
    ATZ
    OK
    AT&N9&C0
    OK
    ATM0L2
    OK
    ATX3
    OK

    RING

    NO CARRIER

    I have changed the initialization line: AT&N9&C0
    a) the &N9 is to (drastically) slow down the modem speed. Without this I cannot get a CONNECT at all (I am on a "fiber to the loop" or some such name...)
    b) &C0 was supposedly (based on what I have read) going to prevent the NO CARRIER by having the modem tell the application that there IS a carrier signal. This does not work.

    So, I am hoping someone out there still knows something about dialup modems and how to use them.

    Thanks!
    Shimon

  2. #2
    Just Joined!
    Join Date
    Jul 2010
    Posts
    23
    Well, I guess the community of us oldies who worked with dialup modems
    way back when, is not so big.
    Anyway, I spoke (offline) to a friend who is older and he reminded me of another
    required setting: the modem must be told explicitly to answer the incoming call!

    I changed the setup string from AT&N9&C0 to AT&N9&C0S0=2 (answer at two rings)
    and behold! It now works! That is, pppd sends ATA to the modem and senses
    the carrier, and then reconnects to the remote server.

    I would add "[SOLVED]" to the thread title, if I knew how.
    Thanks!
    Shimon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •