Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, I am helping out a friend with a new server he got to backup client data, and wants to use Samba for the backup. I have configured Samba on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Feb 2004
    Posts
    139

    [Solved] Samba accross the internet (& NFS)


    Hello,

    I am helping out a friend with a new server he got to backup client data, and wants to use Samba for the backup.

    I have configured Samba on the backup server with the following:
    # Global Parameters

    workgroup = backup
    netbios aliases = pocket
    encrypt passwords = yes
    interfaces = xx.xx.xx.xx
    security = SHARE
    hosts allow = <remote server ip>

    [homes]
    read only = no
    browseable = no

    [backup]
    path = /home/backup
    browseable = yes
    read only = no
    write list = backup
    valid users = backup
    The service starts successfully and there are no firewalls or iptable rules setup yet, however this is what I get when I try to connect remotely:
    root@solaris [~]# smbmount //xx.xx.xx.xx/ /mnt/test -o username=backup,password=******
    timeout connecting to xx.xx.xx.xx:445
    timeout connecting to xx.xx.xx.xx:139
    Error connecting to xx.xx.xx.xx (Operation already in progress)
    17160: Connection to xx.xx.xx.xx failed
    SMB connection failed
    Any idea how I can get this to work?

    Any help appreciated!
    If you love something, emerge it

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Is this server on some sort of LAN?

  3. #3
    Linux Newbie
    Join Date
    Feb 2004
    Posts
    139
    Both servers are in a data center. The only IPs they have are the global IPs on eth0:1, eth0:2, etc.).
    If you love something, emerge it

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    so they aren't 192.168.x.x or 10.x.x.x?
    are they behind any sort of NAT firewall or router?

  6. #5
    Linux Newbie
    Join Date
    Feb 2004
    Posts
    139
    They have 10.x.x.x on the router they are on, however they are both on different routers, and I checked ifconfig and nothing was displayed with that IP and only way to get it is to get the guy to tell me what it says in his server admin panel at the data center, but it wouldn't help anyway.

    Perhaps Samba isn't the way to go accross a network like this? I am trying with NFS now and gotten more success, however I now have a problem with that...

    I have it mounted and the /etc/hosts.deny/allow are setup and /etc/exports, and the daemons all started. I mounted it on the client server (actually my home pc at the moment), but I can no access it.

    ls -al:
    [root@localhost mnt]# ls -al
    total 24
    drwxr-xr-x 7 root root 4096 Dec 8 09:56 ./
    drwxr-xr-x 20 root adm 4096 Dec 8 09:52 ../
    drwxr-xr-x 2 root root 4096 Dec 7 05:37 cdrom/
    drwxr-xr-x 2 root root 4096 Dec 7 05:37 cdrom2/
    drwxrwxrwx 0 root root 0 Dec 8 09:52 floppy/
    drwx------ 2 503 503 4096 Dec 8 08:58 test/
    dr-xr-xr-x 1 root root 4096 Dec 7 13:16 windows/
    I can't chmod or chown /mnt/test (the mount point). What is wrong with that?
    If you love something, emerge it

  7. #6
    Linux Newbie
    Join Date
    Feb 2004
    Posts
    139
    Solved:

    I had to add no_root_squash option to /etc/exports.
    If you love something, emerge it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •