Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I am using the network of my university and I have a IP conflict with a printer. I would like to get a new IP and I am really ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2011
    Posts
    1

    IP conflict and cannot get a new IP


    Hi,

    I am using the network of my university and I have a IP conflict with a printer. I would like to get a new IP and I am really new to these things. I have just found that I had to use the command :

    dhclient -r eth0

    to release the ip. I have tried that but it did not work. The dhcp gives me the same ip again. I have tried to remove the info about eth0 in the file dhclient.leases. But still, I still get the same ip as that printer....

    I have also found that I could use this (without really finding out what it did) :

    /etc/init.d/networking restart

    And I get the same IP again. This is driving me crazy.

    Do you know any other solution ?

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,931
    It sounds like your printer isn't using DHCP. Your DHCP server is trying to keep things consistent for you and knows nothing of your printer's use of that address.

    Either update the printer's settings to use DHCP (or another IP address outside of the range used by DHCP) or update your DHCP server so that it doesn't use that address.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •