Find the answer to your Linux question:
Results 1 to 3 of 3
Hi folks, Ubuntu 11.10 desktop 64 bit Ubuntu can ping IP address but unable to ping IP name. I added gateway 192.168.0.1 on /etc/resolv.conf. However after reboot its content was ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,794

    Fail to connect Internet


    Hi folks,

    Ubuntu 11.10 desktop 64 bit

    Ubuntu can ping IP address but unable to ping IP name. I added gateway 192.168.0.1 on /etc/resolv.conf. However after reboot its content was erased completely.

    I came across this problem before but unfortunately I forgot its fix.

    Any help? TIA

    B.R.
    satimis

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    When you are talking resolving names are these local names or remote/internet names?

    If local names is there a local DNS server?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Nov 2011
    Location
    New Zealand
    Posts
    79
    Quote Originally Posted by satimis View Post
    Hi folks,

    Ubuntu 11.10 desktop 64 bit

    Ubuntu can ping IP address but unable to ping IP name. I added gateway 192.168.0.1 on /etc/resolv.conf. However after reboot its content was erased completely.

    I came across this problem before but unfortunately I forgot its fix.

    Any help? TIA

    B.R.
    satimis
    You dont enter a gateway in resolv.conf - this file is for DNS server entries!

    resolv.conf gets overwritten each time the network service starts or restarts

    Open Network Manager (via System > Administration) and select your interface, usually eth0 if its an ethernet cable connetion - click on IPV4 tab and make sure its set for "Automatic DHCP", save and try it. If it does not work, try "Automatic DHCP address only" and in the "DNS Servers" enter,

    8.8.8.8

    which is Googles DNS server.

    If it still isn't working, can you post your /etc/resolv.conf settings and the output of ifconfig command.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •