Find the answer to your Linux question:
Results 1 to 5 of 5
Hello there. I have a network. One computer has vsFTPd on it. Its internal IP is 10.0.0.6. Another computer (10.0.0.3) is trying to connect: Code: $ ftp ftp> open 10.0.0.6 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    39

    vsFTPd login fail


    Hello there.

    I have a network. One computer has vsFTPd on it. Its internal IP is 10.0.0.6.

    Another computer (10.0.0.3) is trying to connect:

    Code:
    $ ftp
    ftp> open 10.0.0.6
    Connected to 10.0.0.6.
    220 (vsFTPd 2.3.2)
    Name (10.0.0.6:UserName): UserName
    331 Please specify the password.
    Password:
    530 Login incorrect.
    Login failed.
    ftp>
    I am entering the correct password for the user which was set:

    Code:
    $ sudo passwd UserName
    What could be wrong?

    Thank you for your time.

    Kind regards,
    Marius

  2. #2
    Linux Engineer Kloschüssel's Avatar
    Join Date
    Oct 2005
    Location
    Italy
    Posts
    773
    Could the server be misconfigured? There are some specific configuration options that have to be set to enable local users (users in /etc/passwd) to login with their passwords.

    There may be also an encoding problem of your password if you have special characters in it. For example characters with diacritics, circumflexes and especially the german characters ß,ä,ü,ö,etc could cause trouble since they have to be encoded on your client and decoded on the server with the same encoding (i.e. UTF8 vs ISO8859-15 vs ISO8859-1).

    Good luck!
    Last edited by Kloschüssel; 01-03-2012 at 08:00 AM. Reason: typo

  3. #3
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    Code:
    local_enable=YES
    is this enabled in your vsftpd.conf file
    linux user # 503963

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2010
    Posts
    39
    Quote Originally Posted by Kloschüssel View Post
    Could the server be misconfigured? There are some specific configuration options that have to be set to enable local users (users in /etc/passwd) to login with their passwords.

    There may be also an encoding problem of your password if you have special characters in it. For example characters with diacritics, circumflexes and especially the german characters ß,ä,ü,ö,etc could cause trouble since they have to be encoded on your client and decoded on the server with the same encoding (i.e. UTF8 vs ISO8859-15 vs ISO8859-1).

    Good luck!

    "local_enable" is YES.

    Password only contains a-zA-Z0-9.


    Quote Originally Posted by scathefire View Post
    Code:
    local_enable=YES
    is this enabled in your vsftpd.conf file
    Yes. It is enabled.

    UPDATE: If tried logging in with one of the other accounts on the host computer. This was successful. The question then: What could be wrong with the user I logged in previously?

    SOLVED! Opened /etc/passwd and changed /bin/false to /bin/bash


    Thanks.M
    Last edited by kingoslo; 01-03-2012 at 09:30 PM.

  6. #5
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    Is this a real user (as in one with a bash shell) or a virtual user (using /bin/false).

    A lot of times, if your shell is not proper it can cause problems. If you used /sbin/nologin, it has been known to cause login errors with vsftpd. If you used /sbin/nologin, then change it to /bin/false.

    Of course, one way to test it would be to login and test the password.

    If the user has a false shell:
    Code:
    su - UserName -s /bin/bash
    Otherwise
    Code:
    su - UserName
    linux user # 503963

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •