Find the answer to your Linux question:
Results 1 to 3 of 3
The strangest thing just happened to me. The computer is my house is hosed so I used my parents' Windows box to burn a CDLinux live cd. I tested it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    1

    Live CD kidnapped my ethernet card


    The strangest thing just happened to me.

    The computer is my house is hosed so I used my parents' Windows box to burn a CDLinux live cd. I tested it out on their machine, it booted just fine, everything worked, and so I rebooted back to Windows Vista.

    The ethernet card was dead! No link light, the light on the hub was off, there was a big red "X" next to the network icon and Windows insisted that the cable was unplugged. Yet when I booted back into Linux with my live cd all the lights came on, the link light was on, the hub port light was on, I could browse slashdot, etc.

    Grr. This is really embarrassing because I've just hosed my parents' machine and they're really computer phobic people who just use it for email and Microsoft Word.

    I tried everything I could think of. I ran Windows diagnostics. I uninstalled the drivers and then installed them again. I manually deleted the driver .sys file from the harddrive and reinstalled. I unplugged the hub, unplugged the modem, used a different cable. The ethernet card was dead, dead, dead. Dead. Except of course when I ran Linux, during which time it was sweet and innocent and pretended that everything was alright.

    I understand that this is a Linux forum and that configuring Windows is my problem. But what the fark could this CDLinux cd have possibly done to my ethernet card? It has to be some minor configuration change it made, something like changing some value in the card EEPROM or something similar. It seems pretty aggressive for a boot cd to change something permanent like that but I can't think of any other explanation. Maybe my Windows box doesn't like Linux and is being passive-agressive. Who knows.

    The card is an integrated Atheros L2 Fast Ethernet 10/100 Base-T. It's on some sort of Intel chipset, probably used by some Taiwanese manufacturer. The machine is a Brazilian no-name box assembled by a local computer store running Vista 32 bit. It worked just fine right up until the moment I booted it off of the live cd. In fact, I used it to download the live cd iso.

    Any ideas what might be going on? It might actually be easier to fix on the linux side than on the windows side. I have access to all standard windows and linux tools.

    Thanks a lot!

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hello and Welcome!

    A LiveCD wouldn't have done anything to the NIC on the Windows side. That's one of the selling points of a LiveCD.
    One of Vistas' problems, though, is the fact that it will sometimes drop connection for sometimes random reasons.

    The only things I could advise:
    • Ensure that the NIC is enabled in Windows.
    • Power down the modem, reboot into Windows. Then power up the modem.
    • If you are physically connected to a hub/router, repeat the above step for that device.
    • You might be able to perform a system rollback to yesterday.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,042
    Is it turned on (ethernet card) in bios?

    Another culprit could be inadvertent hit of ethernet hot key on keyboard by user.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •