Find the answer to your Linux question:
Results 1 to 3 of 3
I have an issue that's been bugging me for a couple of days, I've had it working in the past so I know it CAN be solved but I'm getting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    3

    Issue connecting to Samba shares


    I have an issue that's been bugging me for a couple of days, I've had it working in the past so I know it CAN be solved but I'm getting to my wits end trying to work it out.

    I have a server which I've had to rebuild from scratch due to disk failure, running Ubuntu Server 10.4, the only changes from out of the box is the installation of openssh-server, samba, fluxbox, xfce4 and gdm.

    The server primarily hosts music for streaming to other PCs or to my WD HD TV Live box which is downstairs. I have imported the smb.conf and interfaces files from my previous installation so there are no changes, the server and WD box are both configured with static IPs in a /24 network. All machines are in a workground config named WIFITEST, no domain config is in use.

    I am able to connect to shares fine using IP but not host name, first thoughts are that this is of course a DNS issue but the problem is that I've NEVER had a stand alone DNS server on the network to handle host records so there was clearly something else in use, maybe a NetBIOS implementation but I can't for the life of me remember what I'd been using.

    The WD box has no means of direct connection via IP (it can only pick up hosts which advertise on the network) so I'm stuck until I can get this working. Likewise there is no hosts file I can edit on the WD box to use the usual hosts workaround where proper DNS isn't available.

    I've read around that the issue may very well be caused by a problem with nmbd (which is running) but I don't know where to start and reading the comments in the conf file isn't getting my any further, has anyone any ideas how I can get the server to broadcast it's host/NetBIOS name? I have a Windows 7 laptop which does show up on the WD box and I have had this config working fine up until the rebuild so it's totally possible.

    I've attatched my interfaces, resolv .conf and smb.conf files for info. smb.conf is the new conf that I've tried to write from scratch, smb.conf.old is the old file which I've also attempted to use.
    Attached Files Attached Files

  2. #2
    Just Joined!
    Join Date
    Apr 2012
    Posts
    3
    bump - anyone?

  3. #3
    Just Joined!
    Join Date
    Apr 2012
    Posts
    3
    Resolved, issue was down to a malfunctioning switch not allowing broadcast packets to reach the network

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •