Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Are you sure your java app is not forking processes? That would explain the many open ports....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677

    Are you sure your java app is not forking processes? That would explain the many open ports.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  2. #12
    Just Joined!
    Join Date
    May 2012
    Posts
    5
    Hi All,

    Thanks for your help. Finally I found the root cause of this issue. We used JMX agent for monitoring Java application. The JMX agent is the root cause for the random LISTEN port. You can find more details in the below link,

    link : stackoverflow.com/questions/516142/does-java-6-open-a-default-port-for-jmx-remote-connections

    More details about remote monitoring and agent please refer below link,

    link : docs.oracle.com/javase/6/docs/technotes/guides/management/agent.html

    Code:
        Remote Monitoring and Management
    
        To enable monitoring and management from remote systems, you must set the following system property when you start the Java VM.
    
        com.sun.management.jmxremote.port=portNum 
    
        In the property above, portNum is the port number through which you want to enable JMX RMI connections. Be sure to specify an unused port number. In addition to publishing an RMI connector for local access, setting this property publishes an additional RMI connector in a private read-only registry at the specified port using a well known name, "jmxrmi".

    - Ramesh

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •