Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Thanks for trying to help me. @hollymolly: I've already tried this. In Debian Sid the corresponding file is /etc/modules.conf and actually I just had to uncomment the lines you mentioned. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Dec 2004
    Location
    Switzerland
    Posts
    8

    Thanks for trying to help me.

    @hollymolly: I've already tried this. In Debian Sid the corresponding file is /etc/modules.conf and actually I just had to uncomment the lines you mentioned. Afterwards I did an update-modules, but it didn't change anything... By the way I don't have these problems when I'm surfing somewhere else (e.g. at school) via WLAN. So I guess it must be something else that doesn't work.

    @Nerderello: My /etc/resolv.conf says:

    search
    nameserver 192.168.1.1

    192.168.1.1 is the IP of my router. As Dapper Dan and jeremy1701 have already pointed out, this must somehow be causing the problem, So maybe I can have my router yield the nameserver IP of my internet provider instead...

  2. #12
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    yup, as you already guessed, that IP address should be the one that your ISP (normally) is providing. I say "normally", because I've managed to add other ISPs's DNS to my config and it seems to work.

    have fun
    and merry Xmas
    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #13
    Just Joined!
    Join Date
    Dec 2004
    Location
    Switzerland
    Posts
    8
    Partial success: I managed to speed up DNS lookups drasticly by manually overwriting /etc/resolv.conf with the nameserver IPs of my ISP!

    The manufacturer of my router told me, though, that there wasn't anything I could change in the router settings because the router actually assigned the DNS addresses of my ISP via DHCP. I'm now thinking of a bash script that can be embedded in my WLAN script (provided by a colleague of mine). It should just overwrite /etc/resolv.conf with the nameserver IPs of my ISP. Can you tell me what such a script could look like (I'm not familiar with bash yet...)?

    Merry Xmas!
    knockey

  4. #14
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    have a look at the scripts in

    /etc/ppp such as ipup

    also have a look at scripts in /etc/sysconfig/network-scripts

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  5. #15
    Just Joined!
    Join Date
    Dec 2004
    Location
    Switzerland
    Posts
    8
    A friend of mine advised me to take a look at /etc/dhclient.conf (as well as man dhclient.conf). I don't know whether this is a Debian-specific file, but at any rate I managed to overwrite the nameserver IPs in /etc/resolv.conf by adding the following statement to /etc/dhclient.conf:

    supersede domain-name-servers 195.186.4.108; # nameserver IP of my ISP

    As long as I only surf at home this actually solves my problem perfectly. But these settings have the disatvantage that nameserver IPs are always overwritten no matter where I surf, i.e. also at school where I've always gotten the correct nameserver IPs right away. These are now overwritten automaticly by the IP of my own ISP, which is again somewhat of a nuisance...

    @ Nerderello: So the idea is that I put a script in ip-up.d that checks the current nameserver settings in /etc/resolv.conf and replaces them if necessary, am I right? I'll try. By the way I don't have a /etc/sysconfig on Debian Sid.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •