Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I'm trying to change my NIC (Intel 10G NIC) settings using ethtool, but can't seem to do that. I tried Code: ethtool -G xge0 rx 32768 tx 32768 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    22

    Unable to change NIC settings with ethtool


    Hi all,

    I'm trying to change my NIC (Intel 10G NIC) settings using ethtool, but can't seem to do that.

    I tried

    Code:
    ethtool -G xge0 rx 32768 tx 32768
    and then tried to see if the settings have changed using

    Code:
    ethtool -g xge0
    But I see the output

    Code:
    Ring parameters for xge0: 
    Pre-set maximums: 
    RX:        4096 
    RX Mini:   0 
    RX Jumbo:  0 
    TX:        4096 
    Current hardware settings: 
    RX:        4096 
    RX Mini:   0 
    RX Jumbo:  0 
    TX:        4096
    Why can't I change the settings?

    Thank you.

    Regards,
    Rayne

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    1. are you root?

    2. some NICs don't support changing some settings. check the output of dmesg for hardware messages, after running ethtool.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •