Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I'm using the Intel 82599EB 10G NIC on a server running RHEL6. I ran a program where packets are generated at high rates. The NIC was previously installed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    22

    Transmit rate decreases when using both Intel NIC 10G ports


    Hi all,

    I'm using the Intel 82599EB 10G NIC on a server running RHEL6. I ran a program where packets are generated at high rates. The NIC was previously installed on another PC where I was able to generate traffic at 8-9Gbps on each port concurrently. On this server, I was able to generate at 8-9Gbps only if one port is in use. If I were to generate on both ports concurrently, then my total transmit rate drops to about 12Gbps (~6Gbps on each port).

    My relevant "lspci -vvv" output shows the following:

    Code:
    0b:00.0 Ethernet controller: ...
          Capabilities: [a0] Express (v2) Endpoint, MSI 00
                LnkCap: Port #1, Speed 5GT/s, Width x8
                LnkSta: Speed 5GT/s, Width x4
                LnkCtl2: Target Link Speed: 5GT/s
    
    0b:00.1 Ethernet controller: ...
          Capabilities: [a0] Express (v2) Endpoint, MSI 00
                LnkCap: Port #1, Speed 5GT/s, Width x8
                LnkSta: Speed 5GT/s, Width x4
                LnkCtl2: Target Link Speed: 2.5GT/s
    Is my transmit rate limited by the "x4" in LnkSta for both ports? And what does it mean to have "Target Link Speed: 5GT/s" on one port and "Target Link Speed: 2.5GT/s" on the other port? Does this contribute to the rate decrease too?

    Also, I see a couple of PCIE slots that are longer than my NIC's PCIE connectors. Can I install my NIC on these longer slots instead?

    Thank you.

    Regards,
    Rayne

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Posts
    5
    Check the link speed on the nic .

    ethtool eth0

    Check if the link is 10gbps or 1 gbps and also check the duplex settings on both the switch and nic .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •