Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Hi, I am having the following problem: I have an application which wants to connect to my server on the port 8080, but this port is somehow unaccessible. Trying with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Posts
    9

    Unable to connect to remote host on port 8080


    Hi,

    I am having the following problem:
    I have an application which wants to connect to my server on the port 8080, but this port is somehow unaccessible.

    Trying with telnet I get:
    telnet XXX.XXX.XXX.XXX 8080
    Trying XXX.XXX.XXX.XXX...
    telnet: connect to address XXX.XXX.XXX.XXX: Connection refused
    telnet: Unable to connect to remote host

    If I try the same on port 80 it works.

    Therefore I tried to open it adding some rules on the iptables, but this didn't solve it.
    I read somewhere else that the problem might be that there is no listener on my server on that port. Do you know what can I do to create a listener? I couldn't find anything that could help me.

    Thank you for your help!

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,168
    Port 8080 is an alternative to http port 80, primarily used for proxy and caching servers, and application servers such as Tomcat. Generally, there is nothing listening for telnet protocols on port 8080, though a Tomcat server may connect that way. Have you started an application on your host that listens on port 8080? Nothing is on that port by default, unless you configure it that way, or it uses that port by default, such as Tomcat.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jul 2012
    Posts
    9
    I am using my server as a VPN and, through this VPN, trying to access a service which apparently needs to connect to port 8080.
    I don't have anything listening on that port..

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,168
    If nothing is listening, then ECONNREFUSED is not an unexpected error. What VPN software are you trying to use?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Just Joined!
    Join Date
    Jul 2012
    Posts
    9
    On the server I have installed OpenVPN..

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,168
    What have you done to configure it? Can you post the configuration file(s) here?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #7
    Just Joined!
    Join Date
    Jul 2012
    Posts
    9
    Server conf:
    Code:
    lport 1194
    ifconfig 172.16.0.1 255.255.255.252
    daemon
    secret /usr/local/psa/var/modules/vpn/vpn-key
    writepid /usr/local/psa/var/modules/vpn/openvpn.pid
    mtu-disc yes
    comp-lzo
    dev tap
    float
    keepalive 10 60
    ping-timer-rem
    resolv-retry infinite
    push "dhcp-option DNS 172.16.0.1"
    push "redirect-gateway def1"
    Server iptables:
    Code:
    iptables -A INPUT -i tap+ -j ACCEPT
    iptables -A FORWARD -i tap+ -j ACCEPT
    iptables -t nat -A POSTROUTING -s 0.0.0.0/0 -d 172.16.0.0/30 -j RETURN
    iptables -t nat -A POSTROUTING -s 172.16.0.0/30 -d 0.0.0.0/0 -j SNAT --to-source XXX.XXX.XXX.XXX
    Client conf:
    Code:
    remote XXX.XXX.XXX.XXX
    nobind
    rport 1194
    ifconfig 172.16.0.2 255.255.255.252
    secret vpn-key.key
    comp-lzo
    dev tap
    float
    keepalive 10 60
    ping-timer-rem
    resolv-retry infinite
    route-gateway 172.16.0.1
    redirect-gateway

  8. #8
    Just Joined! TinoY's Avatar
    Join Date
    May 2012
    Location
    Slovakia
    Posts
    9
    Correct me if I am wrong, but from the server conf I see "lport 1194" so I would assume your application should connect to that port. Or change it to 8080 on both.

  9. #9
    Just Joined!
    Join Date
    Jul 2012
    Posts
    9
    I tried with port 8080 in the config files, but the situation just gets worse:
    now I can't even connect to my VPN server.

    And using
    netstat -tulpn | less
    I don't see any listener on my server on port 8080 yet.

    About the iptables:
    Code:
    Chain INPUT (policy ACCEPT)
    ...
    ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:8080 
    ...
    Server conf:
    Code:
    lport 8080
    ifconfig 172.16.0.1 255.255.255.252
    daemon
    secret /usr/local/psa/var/modules/vpn/vpn-key
    writepid /usr/local/psa/var/modules/vpn/openvpn.pid
    mtu-disc yes
    comp-lzo
    dev tap
    float
    keepalive 10 60
    ping-timer-rem
    resolv-retry infinite
    Client conf:
    Code:
    remote XXX.XXX.XXX.XXX
    nobind
    rport 8080
    ifconfig 172.16.0.2 255.255.255.252
    secret vpn-key.key
    comp-lzo
    dev tap
    float
    keepalive 10 60
    ping-timer-rem
    resolv-retry infinite
    route-gateway 172.16.0.1
    redirect-gateway

  10. #10
    Just Joined!
    Join Date
    Jul 2012
    Posts
    9
    I think I need to add more information.
    My computer in connected to the internet through a VPN.
    I have an application on my computer which needs the port 8080 to be opened in order to communicate with a third internet service.
    Now, somehow the VPN is blocking the communication on port 8080 and the application on my computer doesn't work..
    This is why I thought it was enough to open the port on the server using iptables, but apparently it is not that easy..
    Any idea?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •