Find the answer to your Linux question:
Results 1 to 3 of 3
Hi Guys! I'm currently trying ssh tunnel to a Linux box behind my home dd-wrt router. I'm using PuTTY as the client as I will mainly be connecting to it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Posts
    1

    SSH tunnel to computer behind dd-wrt router


    Hi Guys!

    I'm currently trying ssh tunnel to a Linux box behind my home dd-wrt router. I'm using PuTTY as the client as I will mainly be connecting to it from windows machines. I have been able to connect to it successfully from another computer on my home network but there are issues when I attempt it from off site. I have also enabled ssh on the router itself for management and tunneling. The location I'm tunneling from has a proxy and firewall with ports 22 and 443 open.

    Here's the issue. When I use the router's external IP address, port 443, and the appropriate proxy settings, I am able to connect to the router itself via ssh. If I use port 22, which I think I have forwarded to the box, I get this error message: "Error Code: 502 Proxy Error. The specified Secure Sockets Layer (SSL) port is not allowed. ISA Server is not configured to allow SSL requests from this port. Most Web browsers use port 443 for SSL requests."

    I'm new to networking in general and would greatly appreciate any assistance.

    Thanks in advance!

  2. #2
    Just Joined! PoisonNuke's Avatar
    Join Date
    Aug 2012
    Location
    Germany
    Posts
    1
    Hi,

    simple create a port forwarding on port 22 to the IP of your linux box and disable proxy (if not needed for other applications in your home network).
    And remember to harden the ssh config, because after enable port forwarding it will be reachable for everyone on the world.

  3. #3
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225
    ISA Server is a Microsoft internet firewall, so it looks like port 22 is not open at work. A lot of system administrators change the SSH port in a firewall because they think it increases security.

    [EDIT]

    If you can find out from your sysadmin what port SSH is actually using, you might change your SSH port on the linux machine like this: Setup SSH to run on a non-standard port and in the router, forward that port to the linux box.
    Last edited by hagfish52; 08-10-2012 at 02:49 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •