Find the answer to your Linux question:
Results 1 to 2 of 2
I have debian wheezy with resolvconf, dnsmasq and apache2 running web server for my local domains, i have dynamic ip so the script updates the "/etc/hosts" on each new dialup ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    3

    Cannot ping the local domains with ip 192.168.1.1?


    I have debian wheezy with resolvconf, dnsmasq and apache2 running web server for my local domains, i have dynamic ip so the script updates the "/etc/hosts" on each
    new dialup connection for the new ip.
    The problem is i can ping the global net and the local domain with the ip 127.0.0.1 like one from /etc/hosts "me.example.net"
    but cannot ping the local domains with the ip address 192.168.1.1 like domains from the /etc/hosts.dnsmasq:

    ping example.dynet.com
    PING example.dynet.com (192.168.1.1) 56(84) bytes of data.
    From 58-27-222-13.wateen.net (58.27.222.13) icmp_seq=62 Packet filtered
    From 58-27-222-13.wateen.net (58.27.222.13) icmp_seq=73 Packet filtered
    From 58-27-222-13.wateen.net (58.27.222.13) icmp_seq=79 Packet filtered
    ^C

    --- shams.dynet.com ping statistics ---
    7 packets transmitted, 0 received, 100% packet loss, time 5999ms
    These are the some configuration files related to this issue, this is the /etc/dnsmasq.conf:
    resolv-file=/etc/resolv.dnsmasq
    resolv-file=/etc/resolv.conf
    resolv-file=/etc/ppp/resolv.conf

    #server=/localnet/192.168.0.1
    server=208.67.222.123

    #local=/localnet/
    local=/localnet/192.168.1.1
    local=/example.dynet.com/192.168.1.1
    local=/example.linkpc.net/192.168.1.1

    #address=/double-click.net/192.168.1.1
    address=/example.dynet.com/192.168.1.1
    address=/example.linkpc.net/192.168.1.1

    interface=ppp0
    interface= eth0

    addn-hosts=/etc/hosts.dnsmasq
    #no-hosts
    /etc/resolv.conf
    nameserver 127.0.0.1
    /etc/resolv.dnsmasq:
    nameserver 68.105.28.11
    nameserver 68.105.29.11
    /etc/hosts:
    127.0.0.1 localhost
    117.104.228.40 me.example.net example.net
    /etc/hosts.dnsmasq:
    127.0.0.1 localhost
    192.168.1.1 me.example.net example.dynet.com example.linkpc.net
    /etc/nsswitch.conf:
    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
    /etc/avahi/avahi-daemon.conf:
    domain-name=local
    browse-domains=me.example.net, example.dynet.com, example.linkpc.net
    /etc/avahi/hosts:
    # 2001::81:1 test.local
    192.168.1.1 example.dynet.com.local
    192.168.1.1 example.linkpc.net.loca
    Last edited by shamsat; 08-28-2012 at 07:14 AM.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,512
    You need to edit your firewall rules (iptables and/or ip6tabes) to allow icmp packets. Also, you may need to turn off a flag in /proc/sys/net/ipv4/icmp_echo_ignore_all with the command "echo 0 >/proc/sys/net/ipv4/icmp_echo_ignore_all" (as root or sudo).

    If that doesn't work, then your router may be blocking icmp packets and replies, in which case you will need to alter that to all local pinging of your hosts/servers. You still want to block pings from outside your network as that is a common source of denial-of-service attack.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •