Find the answer to your Linux question:
Results 1 to 3 of 3
Just stup KVM on my Ubuntu 12.04 exactly according to your guide. But, the guest machine can't connect to the network. It can't get an ip through DHCP and it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    18

    Ubuntu 12.04 KVM : Guest Machine Can't connect to the Network!


    Just stup KVM on my Ubuntu 12.04 exactly according to your guide. But, the guest machine can't connect to the network. It can't get an ip through DHCP and it won't work even if I manually set the IP. Please help!

    The /etc/network/interfaces file in the host :

    Code:
    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet manual
    
    auto br0
    iface br0 inet dhcp
            bridge_ports eth0
            bridge_stp off
            bridge_fd 0
            bridge_maxwait 0
    ifconfig results of the bridge :

    Code:
    br0       Link encap:Ethernet  HWaddr d0:27:88:b0:e4:38  
              inet addr:192.168.20.100  Bcast:192.168.20.255  Mask:255.255.255.0
              inet6 addr: fe80::d227:88ff:feb0:e438/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:64 errors:0 dropped:0 overruns:0 frame:0
              TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:8252 (8.2 KB)  TX bytes:7924 (7.9 KB)
    
    eth0      Link encap:Ethernet  HWaddr d0:27:88:b0:e4:38  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:64 errors:0 dropped:0 overruns:0 frame:0
              TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:9148 (9.1 KB)  TX bytes:7970 (7.9 KB)
              Interrupt:41 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    virbr0    Link encap:Ethernet  HWaddr 76:58:19:00:d8:81  
              inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

  2. #2
    Just Joined!
    Join Date
    Aug 2012
    Posts
    18
    I just discovered the problem! Its the firewall! If I disable the firewall, everything works fine! Anyone know how to make it work with the firewall enabled?

  3. #3
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    238
    TH,

    It's a matter of allowing the relevant ports on the firewall. Find out what ports are used to connect to the KVM and also allow DHCP through there.

    Cheers - VP

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •