Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all. I have a new network setup and having problems with connecting my Linux (CentOS) server to the internets. Here is my setup. Modem connects to switch. Windows server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6

    Question Strange setup causing Linux server not to connect to internet.


    Hi all.

    I have a new network setup and having problems with connecting my Linux (CentOS) server to the internets.

    Here is my setup.

    Modem connects to switch.
    Windows server connects to switch and manages the PPPoE connection as well as DHCP and DNS.

    So basically turned my Windows server into a router.

    But when I try to connect to the internet with the Linux web server (connected to the same switch) it fails. It only can do local and not external internet.

    So I am guessing it is a Windows thing that is causing the problem?

    So what can I do to help fix this?

    Thank you!

    Jack,

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by coolkid View Post
    Hi all.

    I have a new network setup and having problems with connecting my Linux (CentOS) server to the internets.

    Here is my setup.

    Modem connects to switch.
    Windows server connects to switch and manages the PPPoE connection as well as DHCP and DNS.

    So basically turned my Windows server into a router.

    But when I try to connect to the internet with the Linux web server (connected to the same switch) it fails. It only can do local and not external internet.

    So I am guessing it is a Windows thing that is causing the problem?

    So what can I do to help fix this?

    Thank you!

    Jack,
    If the Windows box truly is acting as a router, have you tried adding the internal IP address of the Windows box to your Linux routing table as the default gateway? e.g.:

    Code:
    route add default gw <WINDOWS_IP_ADDR> dev eth0
    you might also need to update /etc/resolv.conf with the proper DNS settings (of the format "nameserver <DNS_IP_ADDRESS>").

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •