Find the answer to your Linux question:
Results 1 to 2 of 2
Hi everyone, I have a challenge which needs to be solved: I have 2 desktop systems both running Lubuntu 12.04. PC-1 is mainly used as my main desktop system. PC-2 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! nomko's Avatar
    Join Date
    Dec 2010
    Location
    /home/nomko
    Posts
    7

    Home network with Lubuntu


    Hi everyone,

    I have a challenge which needs to be solved: I have 2 desktop systems both running Lubuntu 12.04.

    PC-1 is mainly used as my main desktop system.
    PC-2 is connected to my flatscreen tv for playing movies. Connected to this system is a 1.5 Terabyte external HDD disc which needs to be accessible from PC-1 (green line)

    Both systems are connected to the router (red line).

    How do I get network access from PC-1 to PC-2 and get access to my ext. HDD disc through the network? It is merely for data transfer (movies/music).

    Anybody here who can give me an easy step-by-step explanation on how to fix this?

    Many thanks in advance!
    Attached Images Attached Images

  2. #2
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    124
    Hi. A NFS share would do it. At first, launch
    Code:
    sudo -s
    in a terminal to easely launch commands.
    You hard drive on PC-2 must be mounted on some mount point, for example /media/external.
    Install "nfs-kernel-server" on both machines.
    Create a mount point on PC-1 with
    Code:
    mkdir /media/external
    On PC-2, declare the NFS share. Add a line with this command
    Code:
    echo "/media/external *(rw)" >> /etc/exports
    then restart nfs server.
    On PC-1, mount the NFS share with
    Code:
    sudo mount -t nfs -o tcp address_of_pc-2:/media/external /media/external
    Once it works, you may add an auto-mount option on your PC-1 with
    Code:
    cat /etc/mtab | grep 'external' >> /etc/fstab
    Don't loose your time with Samba, it's for Windows clients.
    Last edited by CaptainDangeax; 10-11-2012 at 02:32 PM. Reason: little mistake

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •