Find the answer to your Linux question:
Results 1 to 7 of 7
I have a RedHat server running Nagios. When i ping one of the Windows hosts on our LAN it resolves the wrong name? I run the following: [root<at>localhost /]# ping ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2012
    Posts
    4

    Ping returning strange hostname


    I have a RedHat server running Nagios. When i ping one of the Windows hosts on our LAN it resolves the wrong name?

    I run the following:
    [root<at>localhost /]# ping hostA.domain.com

    it returns:

    PING hostA.geneva-trading.com (192.168.105.49) 56(84) bytes of data.
    64 bytes from hostB.geneva-trading.com (192.168.105.49): icmp_seq=1 ttl=127 time=0.197 ms
    64 bytes from hostB.geneva-trading.com (192.168.105.49): icmp_seq=2 ttl=127 time=0.187 ms
    64 bytes from hostB.geneva-trading.com (192.168.105.49): icmp_seq=3 ttl=127 time=0.209 ms

    ??? Why does it return hostB??? It seems to resolve all other hosts I have tried OK. I looked at the Arp, Hosts file and double checked the resolv.conf; everything looks great! I don't get it... Is there another location where resolvers are stored?

    Thanks!
    Tony

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hello and welcome!

    I am guessing that it is a DNS record, either misconfigured or by design. Are you using an internal DNS server?

    In any case, try this:

    Code:
    nslookup 192.168.105.49
    You should get a list of authoritative and non-authoritative DNS names for that ip address.

  3. #3
    Just Joined!
    Join Date
    Oct 2012
    Posts
    4
    WTH! It return the hostB name!!! I don't get it, I am looking at the DNS manager on theserver it used to resolve the name and that is the wrong hostname... Very strange...

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2012
    Posts
    4
    Ah! It's the reverse record! Any idea how to change that? Can I delete it?

  6. #5
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by tlitterio View Post
    Ah! It's the reverse record! Any idea how to change that? Can I delete it?
    Possibly, provided that you are the admin of the DNS server. What kind of DNS server is it?

  7. #6
    Just Joined!
    Join Date
    Oct 2012
    Posts
    4
    It is a Microsoft DNS server, internal. I deleted it. I actually turned on DNS scavenging a number of months back for the forward lookup... Didn't realize it needed to be enabled for reverse separately... All seems to be well now. Thanks!

  8. #7
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Excellent, glad you got it sorted.

    Will mark this thread as Solved for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •