Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hi guys, I'm trying to set up a mini LAN with my Linux box (running Fedora Core 3, kernel 2.6), and my XP box (home, and SP2). I've been trying ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Location
    Dunedin, New Zealand
    Posts
    29

    Sharing a Wireless LAN connection with XP [Fixed]


    Hi guys,

    I'm trying to set up a mini LAN with my Linux box (running Fedora Core 3, kernel 2.6), and my XP box (home, and SP2). I've been trying to find similar situations to mine on the web, but only found people wanting to connect up ethernet ADSL routers to their XP machines. I know that this is similar, and that I've probably overlooked something very simple somewhere along the line.

    This is the way that I've got it set up at the moment:


    Can you see anything wrong with it?

    The Linux box can ping itself (192.168.1.255), but no-one else. XP can ping itself (192.168.1.254), but not Linux (XP can ping everywhere else... it's the one connected to the interenet). It says 'Request Timed Out' in XP. There are no firewalls on the Linux box, SElinux is disabled, and I've also disabled the firewall in FC3. The XP firewall has been told to allow all traffic on the ethernet card. Windows Connection sharing is off (I tried it with it on as well, and no joy). If I enable the Ethernet Adapter in XP, it 'conflicts' with the Wireless LAN (and therefore my internet access, while I know that this is an XP problem and outside the limits of this forum, but you never know what others know ) There is no Samba, nor VNC (I believe that's what it's called) running on either machine, I'm just trying to get access to the internet. I have also tried putting the linux half on a different LAN (192.168.2.*) with no success. The Gateway for the linux box is has been set to the router (192.168.1.1) which (with my basic networking knowledge) *should* be passed on by XP.

    Any suggestions would be muchly appreciated.

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    WA, USA
    Posts
    102
    Before I got my wireless card working in linux, I had a nearly identical setup. (Except SP2 on my XP machine, there are some upgrades that do more damage then good). I just got back from a 19 hour hell trip trying to fly home, so I'll try to post a solution tomorrow if no one else can help you. Right now, I sleep.

    Robert Peaslee
    Taking a walk on the wonderful path computers have lain before me

  3. #3
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    First of all your linux box according to your diagram is connected to a windows box and not the router. For your linux box to get to the internet the windows box it is connected to will have to be set up for internet sharing. With that said the linux box should still be able to ping the windows box in front of it and visa versa. I am suspecting you have a gateway issue with your linux box or a crossover cable between them. I think you will relieve a lot of tension if you set Linux to dhcp and hook it up directly to the router. Or put a wireless card in your linux box and set it up that way.

    As far as a lan you will need to set up samba and set all the workgroup names to be the same for starters. We can help with that but you need to fix your network issues first.

    Mike

    PS Robert where in Washington are you from?
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  4. #4
    Just Joined!
    Join Date
    Dec 2004
    Location
    Dunedin, New Zealand
    Posts
    29
    I figure that once I get this pining issue sorted, I'll be able to setup connection sharing on the XP computer, and get acces to the internet like that.

    The trouble is that I don't have physical access to the router, hence the wireless LAN in the first place. Otherwise, I'd just connect both computers up to the router using ethernet cables.

  5. #5
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Alright,
    Fist of all you have to have a gateway setup in your linux box. looking at your network I am assuming it should be 192.168.1.1

    It can be in one of two places.
    /etc/sysconfig/network-scripts
    pico
    ifcfo-eth0
    blah
    blah
    blah
    gateway = 192.168.1.1

    or
    /etc/sysconfig
    pico network
    blah blah blah
    gateway = 192.168.1.1
    If it isn't in either spot put it in the later.

    then restart eth0
    /etc/init.d/network restart

    If this isn't your problem check your cable to make sure that it isn't a crossover cable.
    put the two ends together facing the same way (tabs down)
    then make sure the colors of the wires are the exact same way and not the opposite meaning if the first wire is white with an orange tracer then that should be the same for the other end. Then same goes for the rest of the wire colors. Say that the colors range one way wo,o,wg,b,wb,g,wb,b and the other side is b,wb,g,wb,b,wg,ow,o then it is a crossover cable and it won't work.

    I hope some of this is clear
    Mike
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  6. #6
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Quote Originally Posted by adrenaline

    If this isn't your problem check your cable to make sure that it isn't a crossover cable.
    put the two ends together facing the same way (tabs down)
    then make sure the colors of the wires are the exact same way and not the opposite meaning if the first wire is white with an orange tracer then that should be the same for the other end. Then same goes for the rest of the wire colors. Say that the colors range one way wo,o,wg,b,wb,g,wb,b and the other side is b,wb,g,wb,b,wg,ow,o then it is a crossover cable and it won't work.

    I hope some of this is clear
    Mike
    I was thinking about this and it might be that you do need a crossover cable since there is no hub between your linux and windows box. I would suggest looking at the cable that is there now and trying the opposite cable.
    Keep me posted,
    Mike
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  7. #7
    Just Joined!
    Join Date
    Dec 2004
    Location
    Dunedin, New Zealand
    Posts
    29
    my ifcfg-eth0 reads:
    Code:
    #Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
    DEVICE=eth0
    ONBOOT=yes
    BOOTPROTO=none
    IPADDR=192.168.1.255
    NETMASK=255.255.255.0
    GATEWAY=192.168.1.1
    HWADDR=00:e0:4c:e1:20:0e
    TYPE=Ethernet
    USERCTL=no
    PEERDNS=yes
    IPV6INIT=no
    The only lines in the above that I don't understand at the BOOTPROTO, and the PEERDNS (I know what a DNS is, but not what that setting refers to).

  8. #8
    Just Joined!
    Join Date
    Dec 2004
    Location
    Dunedin, New Zealand
    Posts
    29
    I've managed to get a hold of a packet sniffer Ethereal, and ran it on the XP machine. It appears as if the pings (from linux) are getting through, but XP isn't responding and vice versa.

    Bizzare huh? The ping packet is standard across all OSs (or am I being wishful)?

  9. #9
    Linux Newbie
    Join Date
    Jul 2004
    Location
    WA, USA
    Posts
    102
    All you need to do is enable ICS on the Wireless Adapter in windows, if using DHCP. (Which I recommend). Don't even bother with your ethernet settings on either box, it will do everything automatically.

    Mike- Around Gig Harbor.

    Robert Peaslee
    Taking a walk on the wonderful path computers have lain before me

  10. #10
    Just Joined!
    Join Date
    Dec 2004
    Location
    Dunedin, New Zealand
    Posts
    29
    Quote Originally Posted by harlequin
    I've probably overlooked something very simple somewhere along the line.
    You beauty... Works brilantly.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •