Find the answer to your Linux question:
Results 1 to 3 of 3
Hello All, I am new the board and wanted to post a question. I am trying to configure samba on RH. The connection I need comes from a windows NT ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2013
    Posts
    2

    Samba Configuration on Linux


    Hello All,

    I am new the board and wanted to post a question. I am trying to configure samba on RH. The connection I need comes from a windows NT 4.0 with SP 6. I have it up and running and can connect from a Windows 7 PC but the NT says incorrect password.

    I created a user called udb and to connect from the win 7 pc, I have to use the servername\udb but it works. The NT says network password wrong. The user on NT is a local account called administrator. I think it is using the computer name\administrator to log on. I tried servernam\udb and just udb but no luck. Below is my smb.conf file.

    Thanks for the help.

    [global]
    workgroup = THUIS
    netbios name = Suskewiet
    # I do not think you will need the following, but if you see complaints
    # about interfaces in your logs, uncomment the line
    # interfaces = eth0 lo
    name resolve order = bcast host lmhosts wins
    server string = Samba file and print server
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    use client driver = yes
    map to guest = Bad User
    local master = yes
    preferred master = yes
    os level = 65
    usershare allow guests = Yes
    usershare max shares = 100
    usershare owner only = False

    [data]

    comment = data
    path = /u01/kla-tencor/data
    force user = udb
    force group = udb
    read only = no
    guest ok = yes
    ; browseable = yes
    ; valid users = yes

    [udb]
    comment = udb
    path = /u01/kla-tencor/udb
    force user = udb
    force group = udb
    read only = no
    guest ok = yes

    ; browseable = yes
    valid users = yes


    security = user
    encrypt passwords = yes

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,844
    I think you need the 'security=' and 'encrypt passwords=' fields under [global] at the top. You should also ensure that the username has a password set on the Linux machine - the server account is used for the authentication. You can also use the 'smbpasswd' command to set a samba password for each windows user on the Linux machine running samba, and it's probably a good idea to do this.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Feb 2013
    Posts
    2
    Thanks,
    I will give that a try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •