Find the answer to your Linux question:
Results 1 to 2 of 2
Hi there, I recently installed openVPN and hit a wall with a issue where the openvpn server's network fail to reach the openvpn's client network. Been googling around and banging ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Location
    Malaysia
    Posts
    15

    openvpn server unable to reach openvpn's client network


    Hi there,
    I recently installed openVPN and hit a wall with a issue where the openvpn server's network fail to reach the openvpn's client network. Been googling around and banging my head but could not come up with a solution/reason for this.

    Here's basically the scenario:
    I have an established openvpn tunnel connection.
    openvpn server (Amazon Linux 2012.09)
    tun0: 10.12.14.1
    eth0: 172.16.100.36

    openvpn client(Centos 6.3)
    tun0: 10.12.14.6
    eth0: 192.168.0.6

    Then, I began to test the tunnel connection by pinging from one end to the other and found one section of the test failed.
    openvpn client ping 10.12.14.1 - OK
    openvpn client ping 172.16.100.36 - OK
    openvpn server ping 10.12.14.6 - OK
    openvpn server ping 192.168.0.6 - FAIL

    I've ensured that the table routes are configured
    [openvpn-server openvpn]# ip route
    default via 172.16.100.1 dev eth0
    10.12.14.0/24 via 10.12.14.2 dev tun0
    10.12.14.2 dev tun0 proto kernel scope link src 10.12.14.1
    169.254.169.254 dev eth0
    172.16.100.0/24 dev eth0 proto kernel scope link src 172.16.100.36
    192.168.0.0/24 via 10.12.14.2 dev tun0

    [openvpn-client openvpn]# ip route
    10.12.14.5 dev tun0 proto kernel scope link src 10.12.14.6
    10.12.14.1 via 10.12.14.5 dev tun0
    172.16.100.0/24 via 10.12.14.5 dev tun0
    192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.6
    169.254.0.0/16 dev eth0 scope link metric 1002
    default via 192.168.0.20 dev eth0

    Iptables are empty for both filter and NAT table and will accept all packets.

    And, ip_forward enabled for both client and server
    [openvpn-server openvpn]# sysctl -a | grep ip_forward
    net.ipv4.ip_forward = 1

    I wonder did I miss anything out. Anyone have any thoughts on this?
    Thanks!

  2. #2
    Just Joined!
    Join Date
    May 2011
    Location
    Malaysia
    Posts
    15
    Issue resolved!

    Looks like I needed to configure the iroute for the openvpn's client subnet. Once I added that, I had to restart the openvpn server and client, and everything was working good.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •