Find the answer to your Linux question:
Results 1 to 7 of 7
I have a D-Link 604 Ethernet Broadband router that I wish to use in order to connect both my Windows XP pro and Linux Fedora Core 3 boxes to the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3

    D-link 604 Broadband Router


    I have a D-Link 604 Ethernet Broadband router that I wish to use in order to connect both my Windows XP pro and Linux Fedora Core 3 boxes to the internet. The Windows box connects just fine through the router, but the linux box does not. I have the linux box set up to obtain network connection info via DHCP from the router, which is what my windows box does. I have had this problem in the past, but I was able to connect to the internet by bypassing the router. I, therefore, know it is the router causing the problem. Is there any way to cofigure the router so it gets along with linux?

    I have even tried turing off DHCP on the router and manually configuring the network settings for both computers. After that, the windows box still works, but the linux box still does not. When I tried to ping the windows box and the router from linux, it turned up a "host unreachable".

  2. #2
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    about host unreachable have you ckecked out the firewall rules in your pc?maybe some ports are closed and you linux box doesn't let ping.about manual configuration without dhcp is an easy part.edit the /etc/hosts like:
    ip <hostname> <alias if u want> for both pc's (windows box and linux box).then setup iptables (man iptables for more).
    Linux For Ever!

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3
    Still not connecting

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    does the router has any firewall enabled?
    Linux For Ever!

  6. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3
    Nope, it is wide open.

  7. #6
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Check the cable from the linux box to the router make sure it isn't a crossover cable. Also give us the out put of ifconfig.
    It doesn't sound like your linux box has a ip address.

    su -
    <password>
    ifconfig

    Make sure in /etc/resolv.conf
    name servers are in there should look like
    nameserver xxxx.xxxx.xxxx.xxxx <x= real IP from ISP>
    nameserver xxxx.xxxx.xxxx.xxxx
    Then check
    /etc/sysconfig/network
    should say
    gateway = <what ever your gateway address is>

    There is some more interesting stuff to look at in
    /etc/sysconfig/network-scripts
    ifcfig-eth0

    Some stuff to look at.

    In the past I have found the routers with DHCP don't always right to all of the right spots in Linux. Different distros write info in different spots.

    Mike
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  8. #7
    Just Joined!
    Join Date
    Dec 2004
    Location
    Dunedin, New Zealand
    Posts
    29
    Go to applications -> System Settings -> Security level, and see what the firewall/SELinux settings are.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •