Find the answer to your Linux question:
Results 1 to 7 of 7
I'm trying to access my server with my dynamic dns address (no-ip.biz) but my router does not support nat loopback. After doing some research I installed bind9 dns server. I've ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2013
    Posts
    4

    dynamic dns local access


    I'm trying to access my server with my dynamic dns address (no-ip.biz) but my router does not support nat loopback.
    After doing some research I installed bind9 dns server. I've added 2 opendns server in named.conf.options as forwarders and a zone in named.conf.local:

    zone "mydomain.zapto.org" {
    type master;
    file "/etc/bind/db.mydomain.zapto.org";
    };

    Now I don't know what I have to do with the db.mydomain.zapto.org file. I've tried some tutorials but none of them work. What do I have to put in this file?

  2. #2
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    883
    For accessing a system that is on a local subnet behind a router or firewall, you need to enable port forwarding on the router or firewall. So, any incoming requests on port (web) 80, 443, should be routed to your local IP address. You do not need to install bind.

  3. #3
    Just Joined!
    Join Date
    Sep 2013
    Posts
    4
    I was not very clear. My server is accessible from outside my network with the dynamic dns address but I want to use the same address for accessing my server locally.

  4. #4
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    883
    The simplest way is to use the hosts file. Just put the server's local IP address in there, and you're good to go.

    If you want to setup bind, check out this tutorial: https://help.ubuntu.com/community/BIND9ServerHowto
    It looks to have all the necessary steps. After you have configured bind, you'll have to point each host on your internal network to your new DNS server manually.

  5. #5
    Just Joined!
    Join Date
    Sep 2013
    Posts
    4
    My db.mydomain.zapto.org file now looks like this but is still doesn't work.

    Code:
    ;
    ; BIND data file for local loopback interface
    ;
    $TTL    604800
    $ORIGIN zapto.org
    @       IN      SOA     ns.zapto.org. root.gmail.com. (
                         2013092639         ; Serial
                                 3H         ; Refresh
                                 15         ; Retry
                                 1w         ; Expire
                                 3h )       ; Negative Cache TTL
    ;
    @       IN      NS      ns.zapto.org.
    ns      IN      A       192.168.1.100
    
    ;also list other computers
    mydomain    IN      A       192.168.1.100

  6. #6
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    883
    Did you update your DNS settings on your client to use the server that has bind running?

    If you run dig mydomain.zapto.org what do you get for the SERVER: out put?

  7. #7
    Just Joined!
    Join Date
    Sep 2013
    Posts
    4
    Yes my DHCP server serves 192.168.1.100 as DNS server. But also when I manually configure the DNS server it doesn't work.
    dig returns my external ip address.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •