Find the answer to your Linux question:
Results 1 to 10 of 10
Hardware: Toshiba Satellite C650D-ST5N01 AMD E-450 processor 8GB RAM OS: Linux Mint 15 KDE, 64bit Problem: When I plug in the ethernet cable, after a couple of minutes, my computer ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2013
    Posts
    10

    Ethernet Connectivity


    Hardware:
    Toshiba Satellite C650D-ST5N01
    AMD E-450 processor
    8GB RAM

    OS:
    Linux Mint 15 KDE, 64bit

    Problem:
    When I plug in the ethernet cable, after a couple of minutes, my computer freezes and sometimes the display spazzes out (pixelates--though that is not the correct term, it's the only one I can think of which best describes the issue). Upon reboot the symptoms are repeated.

    When connected via Wifi all works perfectly.

    Things I have tried (but to no avail):
    1. Tried installing different set of RAM (no change in behavior)
    2. Tried another, similarly set up computer, with same router/modem and cable (this alternate computer works fine--does not display behavior in question)
    3. Tried with a couple of different Live USBs--different distros and the 32bit version of Mint 15 KDE (no change in behavior)
    4. Checked settings in BIOS and Network Manager (all seem fine; no change in behavior)

    Does anyone have any input, suggestions, ideas as to how to remedy this?

    Thank you in advance.
    Last edited by cessanfrancisco; 10-07-2013 at 04:32 PM.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hi,

    have you run a system wide update of kernel and packages yet? As it is Debian-based, I would assume you could do this in a terminal:

    Code:
    sudo apt-get update
    but I'm not sure - not a Linux Mint user myself.

    post your kernel version, and we can check if you have the latest version, if you're not sure.

  3. #3
    Just Joined!
    Join Date
    Oct 2013
    Posts
    10
    Yes, I've run a system-wide update.

    My kernel version is: 3.8.0-31-generic

    It's not the most current version, but I am running the most current version of Linux Mint KDE. Do you think my LAN issues could be stemming from an outdated kernel?

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by cessanfrancisco View Post
    It's not the most current version, but I am running the most current version of Linux Mint KDE. Do you think my LAN issues could be stemming from an outdated kernel?
    I sure do think it is possibly related to either the kernel module/driver for your network adapter, or to the software that controls the network stack.

    I'm not familiar with Linux Mint, though, so I hesitate to give you step by steps guidelines. Hopefully, a Mint pro will be along to better guide you.

    I wonder, does Mint use NetworkManager? I always have that disabled in Fedora b/c I don't like it. Basically, it has the job of switching to the most optimal networking interface based upon the networks it detects. So if you are on wireless, and you plug in wired, it will switch you from the one to the other. If that is installed, I would disable that from the terminal, then do the unplugging, and see if the problem still occurs.

    Also, if you are feeling brave, though, you could check out this tut on updating Linux Mint to the latest kernel available at kernel.org.

  5. #5
    Just Joined!
    Join Date
    Oct 2013
    Posts
    10
    Thanks!

    I'm a total noob so I'm not sure exactly what Mint uses for network management. The desktop environment is KDE so there's configuration all over the place.

    As for a kernel update, I've done that before with disatrous outcomes; it actually made things worse. Having said that, I am leary of doing it again.

    I would, however, like to entertain the notion of updating the LAN drivers. Though I have no idea how to do that. Would you mind giving me some help with that?

    Thanks.

  6. #6
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,001
    I run Mint 14 Mate but I am not on that right now.

    in Mint post

    Code:
    inxi -F
    so members have a better idea of what is going on

    Manual for Mint 15 download


    Naturally our gear is not going to match so me just saying eth0 is no problem or trouble for me is a useless statement.

    Updating the driver

    I would, however, like to entertain the notion of updating the LAN drivers.
    you already covered with this statement.

    Yes, I've run a system-wide update.
    Because if you are running Ubuntu Mint (inxi will tell us). That Mint version is as new as it gets. That is your windows mindset
    thinking about downloading a driver online and upgrading the LAN driver. Your package manager handles all of that on a system
    update so you don't break it.

    Happy trails, Rok
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  7. #7
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    i wonder if you are having an IRQ conflict. Do you have any useful info (warnings/errors) in the syslog, once wired networking starts, but before it locks up?

    it is a stretch, but...are there BIOS updates available for your laptop?

    btw, as rok said, updating your LAN driver is basically achieved by updating the kernel via the OS, so you probably have the latest kernel (and thus, LAN driver) that has been released by LinuxMint, but kernel.org surely has a later version released, though, as you noted, that can be genuine "learning opportunity".

    at any rate, the link i provided before is all I could suggest on doing that.

  8. #8
    Just Joined!
    Join Date
    Oct 2013
    Posts
    7
    CODE[apt-get update] may work.

    TwitterBackground-Coming-Soon-300x168.jpg

  9. #9
    Just Joined!
    Join Date
    Oct 2013
    Posts
    10
    Hi,

    Thanks to everyone for making an effort to help me out, but I've isolated the issue. The ethernet jack is bad. When I wiggle the cable just the slightest bit, even a hair's width, in the jack I am able to manually recreate the issue.

    Thanks again.

  10. #10
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    i had a garbage Toshiba laptop...should have thought of that!

    anyway, glad you got it sorted.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •