Find the answer to your Linux question:
Results 1 to 3 of 3
Hi All, I am trying to connecting to a business's FTPS server. I can connect fine, but when I try issuing the "ls" command it will fail at PASV when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    6

    FTPS using LFTP client. PASV address not being fixed


    Hi All,

    I am trying to connecting to a business's FTPS server. I can connect fine, but when I try issuing the "ls" command it will fail at PASV when trying to list root.

    What happens is it will use a private IP address and try to make the data connection. I've noticed on other servers, it will use the private IP address, but then lftp automatically corrects the IP address and makes the connection using the public. I know they have a range of passive ports open since I do not getting a connection refused when attempting to use the port.

    On the server in question, it does not attempt to fix the address and continues to try and connect on the private IP.

    Any suggestions on what needs to be fixed on their end? Either a router configuration or a setting in the FTPS server?

  2. #2
    Just Joined!
    Join Date
    Apr 2012
    Posts
    6
    Well looks like I found a workaround.
    I set ftp:ignore-pasv-address on and it worked.

    Sorry to waste your time

  3. #3
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    not a waste of time! you've provided an answer to a question that just happened to be of your own posing. future visitors of this thread having the same problem will be grateful.

    marking as Solved for you.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •