Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, This is the router supplied by my ISP (it's 4-port WiFi). I have set it up with CentOS on the server, and I can ping it and ssh into ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Mar 2013
    Posts
    492

    Binatone DT 850W router not allowing me to setup a home webserver


    Hi,
    This is the router supplied by my ISP (it's 4-port WiFi). I have set it up with CentOS on the server, and I can ping it and ssh into it just fine, but it's not allowing port 80 packets, ie. I can't run a browser on the client and Apache on CentOS and have it work. I just poked around in the settings, I went into Access Management and changed ACL To "Deactivated", but it's still not working. What do I do?


    thx.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hi,

    can you explain your setup a little more clearly? are you trying to access the web server on your CentOS box from the outside world? and you can ping and sh into what, the CentOS server or the router? and from where?

  3. #3
    Linux User
    Join Date
    Mar 2013
    Posts
    492
    hey thanks for your help but I solved the problem. the default install of CentOs turns on the firewall. I had to turn it off.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    if you are at all concerned about turning off your firewall, look into adding an iptables rule to allow the web server port in. something like:

    Code:
    -A INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT

  6. #5
    Linux User
    Join Date
    Mar 2013
    Posts
    492
    That's almost exactly what I did except that it was -I INPUT. I'm sorry to say I don't know what I did, I just read it on a website, and had to try it, I was tearing my hair out.
    I'm guessing that this doesn't turn off the entire firewall - how do I do that?

    Thanks.

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    on CentOS, to stop the firewall you'd do this in a terminal (as root):

    Code:
    service iptables stop
    there's also a GUI but i don't mess w/those when i can help it.

    -A is append and -I is insert. From the iptables man page:

    -A, --append chain rule-specification
    Append one or more rules to the end of the selected chain. When the source and/or destination names resolve to more than one address, a rule will be added for each possible address combination.

    -I, --insert chain [rulenum] rule-specification
    Insert one or more rules in the selected chain as the given rule number. So, if the rule number is 1, the rule or rules are inserted at the head of the chain. This is also the default if no rule number is specified.

    Edit: forgot to mention, if you want to permanently disable it, do
    Code:
    chkconfig iptables off
    but i'd recommend figuring out iptables rules.
    Last edited by atreyu; 12-19-2013 at 09:52 PM. Reason: See edit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •