Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, i tried to enable IPv6 networking and after service network restart i seen these messages: FATAL: Error inserting ipv6 (/lib/modules/2.6.18-348.16.1.el5.028stab108.1/kernel/net/ipv6/ipv6.ko): Device or resource busy CRITICAL : [ipv6_test] Kernel is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User postcd's Avatar
    Join Date
    Apr 2011
    Posts
    322

    [ipv6_test] Kernel is not compiled with IPv6 support


    Hello, i tried to enable IPv6 networking and after service network restart i seen these messages:

    FATAL: Error inserting ipv6 (/lib/modules/2.6.18-348.16.1.el5.028stab108.1/kernel/net/ipv6/ipv6.ko): Device or resource busy
    CRITICAL : [ipv6_test] Kernel is not compiled with IPv6 support
    Bringing up loopback interface: [ OK ]
    Bringing up interface eth0: FATAL: Error inserting ipv6 (/lib/modules/2.6.18-348.16.1.el5.028stab108.1/kernel/net/ipv6/ipv6.ko): Device or resource busy
    CRITICAL : [ipv6_test] Kernel is not compiled with IPv6 support
    [ OK ]
    ping6 ipv6.google.com

    returns: socket: Address family not supported by protocol

    Im amateur, can you please suggest how to fix this IPv6 support kernel issue? Please if you get idea on commands i need to do, i will do it.

    Code:
    [root@CentOS-58-64-minimal /]# cat vi /etc/sysconfig/network | grep 6;
    cat: vi: No such file or directory
    HOSTNAME=CentOS-58-64-minimal
    NETWORKING_IPV6=yes
    IPV6FORWARDING=yes
    IPV6_DEFAULTDEV=eth0
    IPV6_DEFAULTGW=2a01:04f8:0191:4150:0000:0000:0000:0000
    # defaultgw was 2a01:4f8:191:4150::2/64
    IPV6_AUTOCONF=yes
    [root@CentOS-58-64-minimal /]# cat /etc/sysconfig/network-scripts/ifcfg-eth0 | grep 6;
    HWADDR=50:46:5d:9f:f8:bf
    IPADDR=144.76.40.81
    SCOPE="peer 144.76.40.65"
    IPV6INIT=yes
    IPV6ADDR=2a01:4f8:191:4150::2/64
    IPV6_DEFAULTGW=fe80::1
    IPV6_DEFAULTDEV=eth0
    [root@CentOS-58-64-minimal /]# cat /etc/sysctl.conf | grep 6;
    # ipv6 settings (no autoconfiguration)
    net.ipv6.conf.default.autoconf=0
    net.ipv6.conf.default.accept_dad=0
    net.ipv6.conf.default.accept_ra=0
    net.ipv6.conf.default.accept_ra_defrtr=0
    net.ipv6.conf.default.accept_ra_rtr_pref=0
    net.ipv6.conf.default.accept_ra_pinfo=0
    net.ipv6.conf.default.accept_source_route=0
    net.ipv6.conf.default.accept_redirects=0
    net.ipv6.conf.default.forwarding=1
    net.ipv6.conf.all.autoconf=0
    net.ipv6.conf.all.accept_dad=0
    net.ipv6.conf.all.accept_ra=0
    net.ipv6.conf.all.accept_ra_defrtr=0
    net.ipv6.conf.all.accept_ra_rtr_pref=0
    net.ipv6.conf.all.accept_ra_pinfo=0
    net.ipv6.conf.all.accept_source_route=0
    net.ipv6.conf.all.accept_redirects=0
    net.ipv6.conf.all.forwarding=1
    net.ipv6.conf.all.proxy_ndp=1
    net.ipv6.bindv6only=1
    net.ipv4.ip_conntrack_max=32760
    [root@CentOS-58-64-minimal /]# uname -a
    Linux CentOS-58-64-minimal 2.6.18-348.16.1.el5.028stab108.1 #1 SMP Tue Aug 27 13:02:53 MSD 2013 x86_64 x86_64 x86_64 GNU/Linux
    Last edited by postcd; 02-27-2014 at 04:51 PM.
    "Avoid the Gates of Hell. Use Linux affordable VPS."

  2. #2
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,294
    This link might help: IPv6-ready kernel

  3. #3
    Linux User postcd's Avatar
    Join Date
    Apr 2011
    Posts
    322
    Thanks for advice, after server restart, errors are away and it now ping6. not sure why reboot was needed when i restarted network.
    "Avoid the Gates of Hell. Use Linux affordable VPS."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •