Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, i read this: Code: # Ignore all ICMP ECHO and TIMESTAMP requests sent to it via broadcast/multicast net.ipv4.icmp_echo_ignore_broadcasts = 1 and i checked my sysctl like this: Code: # ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User postcd's Avatar
    Join Date
    Apr 2011
    Posts
    325

    net.ipv4.icmp_echo_ignore_broadcasts = 1 - but ping works?


    Hello, i read this:

    Code:
    # Ignore all ICMP ECHO and TIMESTAMP requests sent to it via broadcast/multicast
    net.ipv4.icmp_echo_ignore_broadcasts = 1
    and i checked my sysctl like this:

    Code:
    # sysctl -a | grep net.ipv4.icmp_echo
    net.ipv4.icmp_echo_ignore_broadcasts = 1
    net.ipv4.icmp_echo_ignore_all = 0
    so i see its enabled in kernel?

    But why then i can ping to my server from external server and get response? What this value actually do?
    "Avoid the Gates of Hell. Use Linux affordable VPS."

  2. #2
    Linux Newbie
    Join Date
    Jun 2012
    Location
    SF Bay area
    Posts
    173
    The answer is in the comment in the first code block you posted. That settings only controls how the system deals with "broadcast/multicast" packets. ICMP packet that are unicast, meaning sent to one specific server, are outside the scope of the rule.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •