Find the answer to your Linux question:
Results 1 to 5 of 5
Alright I feel stupid and I've been trying for days to get this Askey Computers V1433VQH-X modem to work on my homebuilt AMD machine running Debian testing and kernel 2.6 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    4

    help. modem works but i cant use it


    Alright I feel stupid and I've been trying for days to get this Askey Computers V1433VQH-X modem to work on my homebuilt AMD machine running Debian testing and kernel 2.6
    It works fine in this old Dell junker with Debian stable and kernel 2.2
    Everything on the AMD is newer/bigger/faster than the Dell.
    Debian knows the modem is there but I cant get pppconfig or wvdialconf to see it.
    I followed the instructions from askey at http://www.askey.com/eportal/globalw...enuCatOid=-288
    I've tried all different BIOS and Jumper combinations.
    And the Askey is not a "winmodem" or software based.
    Any help would be great.

    Here's various information from my machine.
    If you'd like to look at anything else, just ask, and tell me where to find it.

    # /var/log/kern.log
    # these are pertinent excerpts

    PnPBIOS: Scanning system for PnP BIOS support...
    PnPBIOS: Found PnP BIOS installation structure at 0xc00fbff0
    PnPBIOS: PnP BIOS version 1.0, entry 0xf0000:0xc020, dseg 0xf0000
    pnp: 00:0b: ioport range 0x260-0x267 has been reserved
    PnPBIOS: 16 nodes reported by PnP BIOS; 16 recorded by driver

    isapnp: Scanning for PnP cards...
    isapnp: Card 'Texas Instruments Inc. V.34+ FAX/Voice Int.'
    isapnp: 1 Plug & Play card detected total
    Serial: 8250/16550 driver $Revision: 1.90 $ 48 ports, IRQ sharing enabled
    ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A






    # /etc/ppp/options

    #these are all the commands that are enabled. this file is the same on #both machines.


    # async character map -- 32-bit hex; each bit is a character
    # that needs to be escaped for pppd to receive it. 0x00000001
    # represents '\x01', and 0x80000000 represents '\x1f'.
    asyncmap 0

    # Require the peer to authenticate itself before allowing network
    # packets to be sent or received.
    # Please do not disable this setting. It is expected to be standard in
    # future releases of pppd. Use the call option (see manpage) to disable
    # authentication for specific peers.
    auth

    # Use hardware flow control (i.e. RTS/CTS) to control the flow of data
    # on the serial port.
    crtscts

    # Specifies that pppd should use a UUCP-style lock on the serial device
    # to ensure exclusive access to the device.
    lock

    # Don't show the passwords when logging the contents of PAP packets.
    # This is the default.
    hide-password

    # Use the modem control lines. On Ultrix, this option implies hardware
    # flow control, as for the crtscts option. (This option is not fully
    # implemented.)
    modem

    # Add an entry to this system's ARP [Address Resolution Protocol]
    # table with the IP address of the peer and the Ethernet address of this
    # system.
    proxyarp

    # If this option is given, pppd will send an LCP echo-request frame to the
    # peer every n seconds. Normally the peer should respond to the echo-request
    # by sending an echo-reply. This option can be used with the
    # lcp-echo-failure option to detect that the peer is no longer connected.
    lcp-echo-interval 30

    # If this option is given, pppd will presume the peer to be dead if n
    # LCP echo-requests are sent without receiving a valid LCP echo-reply.
    # If this happens, pppd will terminate the connection. Use of this
    # option requires a non-zero value for the lcp-echo-interval parameter.
    # This option can be used to enable pppd to terminate after the physical
    # connection has been broken (e.g., the modem has hung up) in
    # situations where no hardware modem control lines are available.
    lcp-echo-failure 4

    # Disable the IPXCP and IPX protocols.
    # To let pppd pass IPX packets comment this out --- you'll probably also
    # want to install ipxripd, and have the Internal IPX Network option enabled
    # in your kernel. /usr/doc/HOWTO/IPX-HOWTO.gz contains more info.
    noipx








    # /etc/ppp/pap-secrets

    # this is the complete file. it is the same on both machines


    # This is a pap-secrets file to be used with the AUTO_PPP function of
    # mgetty. mgetty-0.99 is preconfigured to startup pppd with the login option
    # which will cause pppd to consult /etc/passwd (and /etc/shadow in turn)
    # after a user has passed this file. Don't be disturbed therfore by the fact
    # that this file defines logins with any password for users. /etc/passwd
    # (again, /etc/shadow, too) will catch passwd mismatches.
    #
    # This file should block ALL users that should not be able to do AUTO_PPP.
    # AUTO_PPP bypasses the usual login program so its necessary to list all
    # system userids with regular passwords here.
    #
    # ATTENTION: The definitions here can allow users to login without a
    # password if you don't use the login option of pppd! The mgetty Debian
    # package already provides this option; make sure you don't change that.

    # INBOUND connections

    # Every regular user can use PPP and has to use passwords from /etc/passwd
    * (none) "" *

    # UserIDs that cannot use PPP at all. Check your /etc/passwd and add any
    # other accounts that should not be able to use pppd!
    guest (none) "*" -
    master (none) "*" -
    root (none) "*" -
    support (none) "*" -
    stats (none) "*" -

    # OUTBOUND connections

    # Here you should add your userid password to connect to your providers via
    # PAP. The * means that the password is to be used for ANY host you connect
    # to. Thus you do not have to worry about the foreign machine name. Just
    # replace password with your password.
    # If you have different providers with different passwords then you better
    # remove the following line.

    (none) * password


    "username" provider "password"

    #of course ive changed the real username and password.







    # /etc/serial.conf

    # this is the complete file

    /dev/ttyS0 uart 16550A port 0x03f8 irq 4 baud_base 115200 spd_normal skip_test
    /dev/ttyS1 uart 16550A port 0x02f8 irq 3 baud_base 115200 spd_normal skip_test






    # /etc/wvdial.conf

    #complete file

    [Dialer Defaults]
    Modem = /dev/ttyS1
    Baud = 115200
    Init = ATZ
    Init2 = ATQ V1 R1 S0=0 &C1 &D2
    Phone = 555-5555
    Username = username
    Password = password
    New PPPD = yes
    ISDN = 0
    Modem Type = Analog Modem

    [Dialer pulse]
    Dial Command = ATDP

    Auto Reconnect = off






    # /etc/ppp/peers/provider

    # complete file

    # This optionfile was generated by pppconfig 2.3.5.
    #
    #
    hide-password
    noauth
    connect "/usr/sbin/chat -v -f /etc/chatscripts/provider"
    debug
    /dev/ttyS1
    115200
    defaultroute
    noipdefault
    user "username"
    remotename provider
    ipparam provider

    usepeerdns








    # /etc/chatscripts/provider

    # complete file

    # This chatfile was generated by pppconfig 2.3.5.
    # Please do not delete any of the comments. Pppconfig needs them.
    #
    # ispauth PAP
    # abortstring
    ABORT BUSY ABORT 'NO CARRIER' ABORT VOICE ABORT 'NO DIALTONE' ABORT 'NO DIAL TONE' ABORT 'NO ANSWER' ABORT DELAYED
    # modeminit
    '' ATZ
    # ispnumber
    OK-AT-OK "ATDT5555555"
    # ispconnect
    CONNECT \d\c
    # prelogin

    # ispname
    # isppassword
    # postlogin

    # end of pppconfig stuff







    #output from wvdialconf


    Scanning your serial ports for a modem.

    ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
    ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
    ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
    ttyS1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
    ttyS1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
    ttyS1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
    Port Scan<*1>: S2 S3 S4 S5 S6 S7 S8 S9
    Port Scan<*1>: S10 S11 S12 S13 S14 S15 S16 S17
    Port Scan<*1>: S18 S19 S20 S21 S22 S23 S24 S25
    Port Scan<*1>: S26 S27 S28 S29 S30 S31 S32 S33
    Port Scan<*1>: S34 S35 S36 S37 S38 S39 S40 S41
    Port Scan<*1>: S42 S43 S44 S45 S46 S47


    Sorry, no modem was detected! Is it in use by another program?
    Did you configure it properly with setserial?

    Please read the FAQ at http://open.nit.ca/wvdial/

    If you still have problems, send mail to wvdial-list@lists.nit.ca.







    # output from setserial

    /dev/ttyS0, Line 0, UART: 16550A, Port: 0x03f8, IRQ: 4
    Baud_base: 115200, close_delay: 50000, divisor: 0
    closing_wait: 50880
    Flags: spd_normal skip_test


    /dev/ttyS1, Line 1, UART: 16550A, Port: 0x02f8, IRQ: 3
    Baud_base: 115200, close_delay: 5000, divisor: 0
    closing_wait: 37856
    Flags: spd_normal skip_test

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    What if you disabled PnP in the BIOS? I'm not sure if that would matter on an internal modem, but it could on a serial modem.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    4
    thanks for the input drakebasher. i've tried just about every jumper configuration including no jumpers at all with pnp enabled and disabled.
    the way i had the modem configured in the dell was without any jumpers and irq assignment was handled automatically by the bios.
    i'm starting to think that this is a hardware compatability problem, though it seems absurd to me in this case.

  4. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    4
    Okay this is not a hardware issue. I'm using the modem in question right now with Windows 2000 on the same machine.

    I get a message "LSR safety check is engaged" when i try to use the modem under ttyS0 ttyS2 ttyS3 with no jumpers and the bios set to configure pnp and irq automatically. ttyS1 does not return the "LSR safety check is engaged" on THIS setting, but as i change jumpers and bios settings, the "LSR" message changes from device to device.

    Also if i try to 'setserial -foo /dev/ttyS* fooey' setserial returns "invalid flag /dev/ttyS1" but if i specify 'setserial -foo /dev/ttyS1 fooey' there is no invalid flag error. Note that setserial only returns the 'invalid flag' error for /dev/ttyS1, regardless of bios or jumper settings.

    I can provide any other information if it is needed. Any other ideas or information will be helpful. In any case, I'll be sure to post how/when this is resolved.

  5. #5
    Just Joined!
    Join Date
    Dec 2004
    Posts
    4
    Windows 2000 is accessing the modem through COM3 (ttyS2) irq 4, I/O 0x03f8-0x03ff. I've mimicked the same settings in linux many times already.

    wvdial returns:
    Cannot open /dev/ttyS2: Input/output error

    Here is some more info from my machine..



    #/proc/tty/driver/serial


    serinfo:1.0 driver revision:
    0: uart:unknown port:000003E8 irq:4
    1: uart:16550A port:000002F8 irq:3 tx:0 rx:0
    2: uart:16550A port:000003F8 irq:4 tx:0 rx:0 CTS|DSR|CD|RI
    3: uart:unknown port:000002E8 irq:3
    4: uart:unknown port:000001A0 irq:9
    5: uart:unknown port:000001A8 irq:9
    6: uart:unknown port:000001B0 irq:9
    7: uart:unknown port:000001B8 irq:9
    8: uart:unknown port:000002A0 irq:5
    9: uart:unknown port:000002A8 irq:5
    10: uart:unknown port:000002B0 irq:5
    11: uart:unknown port:000002B8 irq:5
    12: uart:unknown port:00000330 irq:4
    13: uart:unknown port:00000338 irq:4
    14: uart:unknown port:00000000 irq:0
    15: uart:unknown port:00000000 irq:0
    16: uart:unknown port:00000100 irq:12
    17: uart:unknown port:00000108 irq:12
    18: uart:unknown port:00000110 irq:12
    19: uart:unknown port:00000118 irq:12
    20: uart:unknown port:00000120 irq:12
    21: uart:unknown port:00000128 irq:12
    22: uart:unknown port:00000130 irq:12
    23: uart:unknown port:00000138 irq:12
    24: uart:unknown port:00000140 irq:12
    25: uart:unknown port:00000148 irq:12
    26: uart:unknown port:00000150 irq:12
    27: uart:unknown port:00000158 irq:12
    28: uart:unknown port:00000160 irq:12
    29: uart:unknown port:00000168 irq:12
    30: uart:unknown port:00000170 irq:12
    31: uart:unknown port:00000178 irq:12
    32: uart:unknown port:00000302 irq:3
    33: uart:unknown port:00000302 irq:3
    34: uart:unknown port:00000302 irq:3
    35: uart:unknown port:00000302 irq:3
    36: uart:unknown port:00000302 irq:3
    37: uart:unknown port:00000302 irq:3
    38: uart:unknown port:00000302 irq:3
    39: uart:unknown port:00000302 irq:3
    40: uart:unknown port:00000302 irq:3
    41: uart:unknown port:00000302 irq:3
    42: uart:unknown port:00000302 irq:3
    43: uart:unknown port:00000302 irq:3
    44: uart:unknown port:00000000 irq:0
    45: uart:unknown port:00000000 irq:0
    46: uart:unknown port:00000000 irq:0
    47: uart:unknown port:00000000 irq:0







    #/proc/interupts



    CPU0
    0: 1189262 XT-PIC timer
    1: 1324 XT-PIC i8042
    2: 0 XT-PIC cascade
    5: 83 XT-PIC uhci_hcd, uhci_hcd
    7: 1317 XT-PIC parport0
    8: 1 XT-PIC rtc
    9: 0 XT-PIC acpi
    10: 49245 XT-PIC EMU10K1, r128@PCI:1:0:0
    11: 30 XT-PIC ohci1394, eth0
    12: 45942 XT-PIC i8042
    14: 6185 XT-PIC ide0
    15: 1 XT-PIC ide1
    NMI: 0
    LOC: 1189229
    ERR: 34
    MIS: 0






    #/proc/ioports



    0000-001f : dma1
    0020-0021 : pic1
    0040-005f : timer
    0060-006f : keyboard
    0070-0077 : rtc
    0080-008f : dma page reg
    00a0-00a1 : pic2
    00c0-00df : dma2
    00f0-00ff : fpu
    0170-0177 : ide1
    01f0-01f7 : ide0
    0213-0213 : ISAPnP
    0260-0267 : pnp 00:0b
    02f8-02ff : serial
    0376-0376 : ide1
    0378-037a : parport0
    037b-037f : parport0
    03c0-03df : vga+
    03f6-03f6 : ide0
    03f8-03ff : serial
    0a79-0a79 : isapnp write
    0cf8-0cff : PCI conf1
    5000-500f : 0000:00:07.4
    6000-607f : 0000:00:07.4
    c000-cfff : PCI Bus #01
    c000-c0ff : 0000:01:00.0
    d000-d00f : 0000:00:07.1
    d000-d007 : ide0
    d008-d00f : ide1
    d400-d41f : 0000:00:07.2
    d400-d41f : uhci_hcd
    d800-d81f : 0000:00:07.3
    d800-d81f : uhci_hcd
    dc00-dcff : 0000:00:0f.0
    dc00-dcff : 8139too
    e000-e01f : 0000:00:11.0
    e000-e01f : EMU10K1
    e400-e407 : 0000:00:11.1
    e400-e407 : emu10k1-gp


    Happy Happy Joy Joy..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •