Find the answer to your Linux question:
Results 1 to 4 of 4
I cannot get eth0 up on Linux kernel 2.6 at all. I was able to do so on 2.4 with no problem, but both on an upgrade to 2.6, and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Location
    Piscataway, NJ
    Posts
    27

    Another "siocsifflags" problem


    I cannot get eth0 up on Linux kernel 2.6 at all. I was able to do so on 2.4 with no problem, but both on an upgrade to 2.6, and a fresh install of Mandrake 10.1 (which includes 2.6) anytime I enter the command "ifconfig eth0 up" as root, I get this:

    SIOCSIFFLAGS: Function not implemented

    I've tried every setting I can think of, DHCP, static IP, and so on. I went through the Mandrake wizard many times. I removed the connection completely and added it back in many times. I think I tried everything besides recompiling the kernel.

    Can someone tell me what I'm missing?

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    What kind of NIC are you using?

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Location
    Piscataway, NJ
    Posts
    27
    I used two different types. One that was intergrated with my motherboard, and a seperate ethernet card. Note that there was a complete reformat and installation of my distro between me trying both cards. I'm not sure of the exact make or model on the seperate one, but it was fairly standard. My motherboard is a Soyo P4X400 Dragon Lite.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2004
    Location
    Piscataway, NJ
    Posts
    27
    I figured it out. ACPI messed everything up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •