Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    ifconfig Command Does Not Show IPv4 Address


    I did a network restart on my RHE Santiago 6.5 server and lost all connectivity. when i do an IF config, i dont see any ipv-4 information.

    i did an # vi /etc/sysconfig/network-scripts/ifcfg-eth0 and i can see the ipaddress, gw and netmask information there. i tried to bring the nic down and back up but still no ipv4 information.

    with that said, when i setup the server a year or so ago, i renamed eth0 and eth1 to c4c&network as i had multiple nics and wanted to know which is what. when i try to edit vi /etc/sysconfig/network-scripts/ifcfg-c4c or vi /etc/sysconfig/network-scripts/ifcfg-network. it says permission denied. i dont recall putting a password on any of this. i made sure i am the superuser.

    any idea what my options are to bring this server back up?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    14,038
    -->
    Check the permissions on the /etc/sysconfig/network-scripts directory as well as the files in particular. They directory and files should be read access only for non-root users. You say you are the superuser (root?) - are you sure? How are you getting superuser access? Please show details.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •