Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    BIND Configuration


    Hello!

    I have a server which hosts a domain, name.tk. I want to use my server as a nameserver, so I use BIND. The problem is that I do not know how to properly configure BIND.

    So I have the /etc/named.conf: attachment 1

    And this is mine zone file for the nameservers: attachment 2

    In my domain management, I added ns1.name.tk ns2.name.tk as glue records, and I changed the nameserves to my own (ns1.name.tk and ns2.name.tk).

    However, these nameservers cannot be found from other computer. Only on my server I can view them.

    (name.tk is not the real domain and 1.2.3.4 is the public IP of the server)

    What I am doing wrong?

    Thank you in advance!!!
    Attached Files Attached Files

  2. #2
    -->
    I fixed it.

    The problem was that I did not have port 53 forwarded and that I did not have
    Code:
    allow-recursion { 192.168.0.1; 127.0.0.1; };
    And some setting in the domain management panel.

    Now it works perfectly!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •