Find the answer to your Linux question:
Results 1 to 5 of 5
I have recently installed DWL-G520 (rev B), Atheros based wireless LAN card on FEDORA CORE 3. Now the problem is that whenever i try to activate the card with ifup ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Pakistan
    Posts
    4

    Wireless Card installed but problems in configuring.


    I have recently installed DWL-G520 (rev B), Atheros based wireless LAN card on FEDORA CORE 3.

    Now the problem is that whenever i try to activate the card with ifup ath0 command it gives the

    following error message.


    Error for wireless request "Set Encode" (8B2A) :
    SET failed on device ath0 ; Invalid

    argument.

    Determining IP information for ath0... failed.



    Can anyone help me out of it? I have tried static ip settings but that also to does not seem to

    work. Please guide me how to proceed? My confgurations are as follows since i want to work in

    Adhoc Mode.

    My configuration file is /etc/sysconfig/network-scripts/ifath0 and its contents are:

    ONBOOT=yes
    DEVICE=ath0
    BOOTPROTO=yes
    WIRELESS=yes
    MODE=Ad-hoc
    ESSID=fahad
    CHANNEL=7


    Waiting for someone to HELP?

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Okay,
    1) Which distro are you using?
    2)Are you using the MadWifi drivers? Because if so, according to google.com/linux, AdHoc mode doesn't work with the MadWifi drivers.
    3)If you are using the MadWifi drivers, then I'd suggest you try ndiswrapper.
    -lakerdonald

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Pakistan
    Posts
    4

    i am using FC 3

    And i hav installed the madwifi drivers.

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Well then Ad-Hoc isn't going to work. I suggest that you try ndiswrapper.

  5. #5
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    or just switch to
    Code:
    MODE=managed
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •