Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi, this is my first time using Linux, so your kind patience and help is much appreciated. I installed Fedora Core 3 on my laptop without hitches, and now I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    27

    help needed: getting Intel Wireless/Pro 2100 to work


    Hi, this is my first time using Linux, so your kind patience and help is much appreciated.

    I installed Fedora Core 3 on my laptop without hitches, and now I'm trying to get the Intel Pro/Wireless miniPCI 2100 to work.

    I was following the instructions on http://frealek.dotnode.com/blog/view/177 and after installing the iwtools, I was supposed to check if the installation was good by typing "iwconfig --version". However, it gave "bash: iwconfig: command not found". Yet, when I opened the config file, CONFIG_NET_RADIO is set to "y". So what is the problem here?

    Help much needed and appreciated.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Code:
    whereis -b iwconfig
    if that returns anything, then you have it installed, and just need to export it's path to your $PATH environment variable, or run it with its full path.

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    27
    I did a "whereis iwconfig" and got this:
    iwconfig: /sbin/iwconfig /usr/share/man/man8/iwconfig.8.gz

    So how do I export it to my $PATH?

    And I've another question (which shouldn't belong in this forum, but I didn't want to make so many posts), I'm using KDE desktop on FC3, and I created a vfat drive (/opt/) during installation. However, when I login as a normal user, I can't write to that drive. Didn't use to have this problem when using GNOME... How do I modify the access permissions in KDE such that I get to write to that drive as a normal user?

    Thanks!

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Add this to the line in your /etc/fstab about the /opt partition under options:
    "users"

    Uh, you can do this:
    add to your ~/.bashrc:
    PATH=$PATH;/sbin
    export $PATH;

    although it sounds like you just aren't doing things as root, but really any system wide configuration like networking needs to be done as root.

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    27
    Oh. I login as user on the bootup screen, but use the "su" option in the terminal when trying to do changes. That's coz I thought it was recommended not to login as root all the time? :P

  6. #6
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Oh, well you have to use the handy '-' flag, which will give you root's environment as well as his permissions:
    Code:
    su -
    Took me about four months on linux to learn that part of the su command

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    27
    Hmm... sorry for being such a newbie, but when I opened my /etc/fstab file, I didn't see any options where I can add "users"?

    And another thing, how do I change the "Security mode: Open" to Shared?

    Thanks!

  8. #8
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Quote Originally Posted by arctos
    Hmm... sorry for being such a newbie, but when I opened my /etc/fstab file, I didn't see any options where I can add "users"?
    try something like this
    Code:
    /dev/hd**  /opt  reiser  users,rw  00
    so put the users between the file system (in my example it is reiserfs) and the numbers, and make it joined up to any other words that are there my a , (comma).

    hope this helps;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  9. #9
    Just Joined!
    Join Date
    Jan 2005
    Posts
    27
    I've finally got my wireless to work, thanks guys.

    But the drive problem is still there. I've added in users,rw after the defaults, but I still can't write to the drive. Worst still, now I can no longer see the files that were originally on the drive. (O_o)

  10. #10
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Can you post your /etc/fstab here?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •