I found these intructions on another site and thought I'd post them here. I haven't tried them yet, but everyone seems to be having good luck with it.

Hey guys,

I just managed to get the WMP54G going under Mandrake 10 Official Download. I will try to give you as much detail as I can.

The following instructions tell you how to download and setup ndiswrapper from scratch. Make sure that the package that comes with Mandrake 10 is NOT installed. If it is, go to "configure your computer", "software management" and remove it. While you are in there, make sure that teh "wireless tools" are installed.

The commands below start with a dollar sign. The dollar sign represnts the prompt. Do not type the dollar sign.

Download ndiswrapper from http://sourceforge.net/projects/ndiswrapper/
Open a shell and go to where ndiswrapper-0.7.tar.gz is located
Untar the file by running
$ tar -zxvf ndiswrapper-0.7.tar.gz
Go into the newly created directory
$ cd ndiswrapper-0.7
I would strongly reccomend reading the INSTALL file. All I did is follow the steps in it. You can open it vi.
$ vi INSTALL
To exit vi type :q that's colon q
To install the ndiswrapper run
$ make install

Now you can install the windows drivers. I had problems with the windows drivers I downloaded from the internet. The once from the CD worked better.
$ ndiswrapper -i /mnt/cdrom/Drivers/wmpci54g.inf
Please substitude the path or filenames if different to match yours.

To see if it worked
$ ndiswrapper -l
You should see
Installed ndis drivers:
bcmwl5 present

Load the module
$ modprobe ndiswrapper

To see if the module loaded type
$ dmesg
I was getting some errors here. Rebooting seemed to make the module load ok. Eventually I removed ndiswrapper and started over again. To remove it I just did $ rm -f /usr/bin/ndiswrapper Do this only if you have problems.

Now you should see it as wlan0 when you run the following:
$ iwconfig

Set the mode to managed by running
$ iwconfig wlan0 mode Managed

I have not set up encryption yet, but you can set it up by running the following command and replacing the Xs with your own key composed of numbers and letters 0-9 A-F I believe. This same number will have to be entered into your access point as well.
$ iwconfig wlan0 key restricted XXXXXXXXXX

Your access point has SSID or ESSID. Enter it here
$ iwconfig wlan0 essid ESSID

Now you should be able to see the information you just entered by typing
$ iwconfig

This is where I had problems. The ESSID remained blank no matter how many times I entered it. Also the access pint came up as all Fs. This is when I started over by deleting ndiswrapper. Now it reports the proper ESSID and access pint.

Here is where the INSTALL file tells you to setup the network parameters of wlan0. I did not change anything but you can look them up in Mandrake 10 by going to "Configure your computer", "Network and Internet", "Manage connetions". You should see wlan0 in the drop down menu. I made sure that "Start at boot" is checked under "Options". TCP/IP I left blank to be assigned by DHCP.

At the command prompt run as root
$ ifconfig

If you do not see wlan0 listed try
$ ifconfig wlan0 up

try again
$ ifconfig

Now you should see wlan0 with an IP address assigned.

To have ndiswrapper load at boot
$ ndiswrapper -m

Hopefully this helps.

Nick

written by nrnickolov