Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, Being a linux newbie , i was on lookout for driver for this modem and finally found one for rh9 which was on motorola site. When i tried installing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    2

    Trouble installing sm56 speakerphone modem driver in Fedora1


    Hi,
    Being a linux newbie , i was on lookout for driver for this modem and finally found one for rh9 which was on motorola site. When i tried installing it ,the installation was successful but when i tried "modprobe" i get the following messages:
    [senthil331@localhost senthil]$ /sbin/modprobe sm56
    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/char/sm56.o: unresolved symbol tt y_register_driver_R536a8785
    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/char/sm56.o: unresolved symbol re gister_chrdev_R798ae190
    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/char/sm56.o: unresolved symbol ir q_stat_R95cc1909
    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/char/sm56.o: unresolved symbol tt y_unregister_driver_R88d97e89
    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/char/sm56.o:
    Hint: You are trying to load a module without a GPL compatible license
    and it has unresolved symbols. The module may be trying to access
    GPLONLY symbols but the problem is more likely to be a coding or
    user error. Contact the module supplier for assistance, only they
    can help you.

    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/char/sm56.o: insmod /lib/modules/ 2.4.22-1.2115.nptl/kernel/drivers/char/sm56.o failed
    /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/char/sm56.o: insmod sm56 failed
    [senthil331@localhost senthil]$

    Plz help me,
    Thanks,

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4

    Re: Trouble installing sm56 speakerphone modem driver in Fed

    Hi,

    Please send your request to softmodem@motorola.com.
    The request attachments should be follows:
    1) result of 'lspci -nv' command or 'cat /proc/pci' to identify modem model.
    2) result of 'cat /proc/version' command to identify linux kernel version.


    Regards,
    AlGl

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •