I am install the redhat 9 linux but i can't find the real driver (modul) for my modem ess es56s th-pi chipset es2898 .The kernel version of redhat is 2.4 ,and i find the driver for kernel 2.2.18 but it doesn't work because the error was the module is compiling for gcc version 2 and your kernel is compiled with version gcc 3 - and he said it can't work. please can you help me with my problem i wan't go with my redhat to the internet because i like redhat very well.Soory for my bed english!