Find the answer to your Linux question:
Results 1 to 5 of 5
Hello guys! I have 2 machines. My workstation with Debian Sarge and a server with Red Hat AS 3. From my machine I achieve to run remote applications from several ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    São Paulo - Brazil
    Posts
    3

    Remote Access error


    Hello guys!

    I have 2 machines. My workstation with Debian Sarge and a server with Red Hat AS 3.

    From my machine I achieve to run remote applications from several other servers (Red Hat 8, HP-UX, Solaris 8, etc). But from this specific server (just installed) I receive the error:

    Gtk-WARNING **: cannot open display:

    Someone can help me?

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    http://tldp.org/HOWTO/XDMCP-HOWTO/ssh.html

    As a general tip though, it is suicide to use X11 on a server.

    Have fun!

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Location
    São Paulo - Brazil
    Posts
    3
    Thanks for your replay Kriss!

    Although I do not use Windows, at least the link suggested by you motivated me to enable SSH server instead the telnet still used by us (yes, I know how much it is insecure). Unfortunately the same message when I tryed for example to open Gnome Editor:
    (gedit:11661): Gtk-WARNING **: cannot open display:

    Follow the steps I've done:

    1- I type in my host: xhost +<remoteIP>
    2- From my workstation (Debian Sarge) I connect to the server (using telnet or, now, SSH).
    3 - If I used telnet I type in prompt ($ or #): gedit -display myIP:0.0. If I used ssh, just type the command. In both cases, the result is the error pasted above.

    This is the first RH AS in our network, with others server, I never had any problem.

    I'm still reading the manual that cames with the system, but if someone has any clue, please tell me!

    Thanks again,

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Location
    São Paulo - Brazil
    Posts
    3

    Working!

    Hello guys,

    Just for feedback in order to help anybody with this problem.

    The only thing I had to do was uncomment these lines from the file /etc/ssh/ssh_config:

    Host *
    ForwardX11 yes (I have changed from no to yes).

    Easy. But when a still didn't know



    Thanks everybody,

  5. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    1

    it works!

    hi,
    I was unable to open X applications from a remote system while running ssh. Thanks to the information given abouy the ssh_config file , I have solved my problem. However I came across a lot of settings in the config file. I am curious about these settings, can someone tell me about the most commonly used settings.
    TIA
    pankaj

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •