Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
Below is the Samba config/ I have use smbpasswd -a command to set the password. [global] server string = Wibble obey pam restrictions = Yes pam password change = Yes ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5

    Below is the Samba config/

    I have use smbpasswd -a command to set the password.

    [global]
    server string = Wibble
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*success fully*
    unix password sync = Yes
    log file = /var/log/samba/%m.log
    max log size = 0
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    dns proxy = No
    wins support = Yes
    printing = cups

    [homes]
    comment = Home Directories
    valid users = %S
    read only = No
    create mask = 0664
    directory mask = 0775
    browseable = No

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    [LBShare]
    comment = Basic share
    path = /share
    guest account = muttley
    read only = No
    guest ok = Yes
    hosts allow = mattise

  2. #12
    Just Joined!
    Join Date
    Mar 2005
    Location
    Eastbourne, UK
    Posts
    68

    Re: XP can see Samba but cannot access share

    Quote Originally Posted by JimBean
    Hello

    I've got a problem getting my XP system to see a Samba share.
    Did you get this sorted out? I've been in much the same boat (the behaviour you described in the first post is excatly what I've been seeing). the only thing I haven't done is added the user using smbpassword - although I do remember trying in an earlier iteration and the command could not be found.

    I'll going to be having another crack at this tonight so any suggestions would be great. Even a success story might give a little encouragement.

    Mark

  3. #13
    Linux User
    Join Date
    Feb 2005
    Posts
    290
    Quote Originally Posted by JimBean
    Below is the Samba config/

    I have use smbpasswd -a command to set the password.

    [global]
    server string = Wibble
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*success fully*
    unix password sync = Yes
    log file = /var/log/samba/%m.log
    max log size = 0
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    dns proxy = No
    wins support = Yes
    printing = cups

    [homes]
    comment = Home Directories
    valid users = %S
    read only = No
    create mask = 0664
    directory mask = 0775
    browseable = No

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    [LBShare]
    comment = Basic share
    path = /share
    guest account = muttley
    read only = No
    guest ok = Yes
    hosts allow = mattise
    try to add yourself a netbios name as well as workgroup and see the result? "obey pam restrictions = Yes" sounds irritating to me... perhaps you might want to comment it out, restart your samba server and try to connect again :P


    or try something easier like
    Code:
    [global]
        workgroup = <yourworkgroup>
        netbios name = sambarocks
    &#91;test&#93; 
        comment = For testing only
        path = /tmp
        read only = no
        guest ok = yes
    restart your samba server and try if you can access the samba machine

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Oct 2009
    Posts
    1

    Check Firewall

    I had the same problem until I discoverd the firewall was all closed to the outside, as its default settings should be. Open them up and look, there's the desired login windows followed by the defined acces possibilities.
    Tuning the Conf file can of course never change firewall settings. If they're the bottleneck, leave the conf file as it is until firewall is configured for external access.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •