Find the answer to your Linux question:

View Poll Results: Did this how to help you?

Voters
2. You may not vote on this poll
  • Yes

    1 50.00%
  • No

    1 50.00%
Results 1 to 9 of 9
I had success installing my airlink101 AWLC4030 Super G Wireless Cardbus Adapter . This device uses the atheros drivers which in linux are called the madwifi drivers and as you ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie imdeemvp's Avatar
    Join Date
    Sep 2004
    Location
    California
    Posts
    225

    How to install ATHEROS drivers for wireless card in FC3.


    I had success installing my airlink101 AWLC4030 Super G Wireless Cardbus Adapter. This device uses the atheros drivers which in linux are called the madwifi drivers and as you can see you can get these packages from atrpms. If you have this repository in your yum.conf you can install via yum and a dependency will be needed to install the drivers. The dependency is installed according to your kernel version. Please note that everytime you upgrade the kernel reinstallation of dependency is required.

    UPDATE: Let us begin by adding atrmps to your repo data base, if you already have it skip this step . Now open terminal and become root and run this command:
    Code:
    gedit /etc/yum.repos.d/atrpms.repo
    and add this lines:
    [atrpms-stable]
    name=ATrpms for Fedora Core $releasever stable
    baseurl=http://apt.atrpms.net/fedora/$releasever/en/$basearch/at-stable
    enabled=1
    gpgcheck=1
    and click on SAVE , also root import the gpg key from the terminal: rpm --import http://atrpms.net/RPM-GPG-KEY.atrpms

    For example I am using:
    [imdeemvp@myfc3 ~]$ uname -r
    2.6.10-1.760_FC3
    [imdeemvp@myfc3 ~]$
    Which requires me to install this dependency first: madwifi-kmdl-2.6.10-1.760_FC3-0.9.4.12-15.rhfc3.at.i686.rpm so I ran yum command:
    Code:
    yum install madwifi-kmdl-2.6.10-1.760_FC3-0.9.4.12-15.rhfc3.at.i686.rpm
    once this is installed you can run yum command:
    Code:
    yum install madwifi
    and this is the result:
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package madwifi.i386 0:0.9.4.12-15.rhfc3.at set to be installed
    --> Running transaction check

    Dependencies Resolved
    Transaction Listing:
    Install: madwifi.i386 0:0.9.4.12-15.rhfc3.at
    Is this ok [y/N]: y
    Downloading Packages:
    madwifi-0.9.4.12-15.rhfc3 100% |=========================| 2.4 kB 00:00
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Installing: madwifi 100 % done 1/1

    Installed: madwifi.i386 0:0.9.4.12-15.rhfc3.at
    Complete!
    We are not done you may run into some issues like I did. My wireless was SLOW so I asked for help and this was the SOLUTION!

    You may also need some extra tools to monitor your wireless connection and in this tutorial you can learn how to do it. I am posting my wireless configuration:
    [imdeemvp@myfc3 ~]$ cat /etc/sysconfig/network-scripts/ifcfg-ath0
    # Please read /usr/share/doc/initscripts-*/sysconfig.txt
    # for the documentation of these parameters.
    IPV6INIT=no
    ONBOOT=yes
    USERCTL=yes
    PEERDNS=no
    GATEWAY=
    TYPE=Wireless
    DEVICE=ath0
    HWADDR=00:0f:axbd:ax <<- this was modified before posting
    BOOTPROTO=dhcp
    NETMASK=
    DHCP_HOSTNAME=
    IPADDR=
    DOMAIN=
    ESSID=
    CHANNEL=6
    MODE=Managed
    RATE=36Mb/s
    [imdeemvp@myfc3 ~]$
    I created this little how to in my laptop as I was wireless connected! I am also posting some screenshot to give you an idea how your setting should look like. ONE quick tip I make the NetworkMangerInfo start during my login by adding it to session >startup program

    IF YOU HAVE CONNECTION PROBLEMS DO THE FOLLOWING: You can try to download the kernel http://atrpms.net/dist/fc3/kernel/ burn in a cd, copy to hard drive and install it and do same for madwifi drivers and make sure you are VERY careful in the kernel you choose. OR if you have a pen flash drive save it there and transfer it to you fc3 box! Also note the that drivers are supported from kernel 2.6.10-737 and higher.

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3

    Different Kernel

    Hi I have a Netgear WG311T which needs madwifi to run however my kernel is 2.6.9-1.667 and atrpms doesn't make a madwifi driver for that kernel. I was wondering if you knew how I can update my kernel without internet access on my Linux partition?

    I'm running Fedora Core 3 by the way.

    Thanks,

  3. #3
    Linux Newbie imdeemvp's Avatar
    Join Date
    Sep 2004
    Location
    California
    Posts
    225
    You can try to download the kernel http://atrpms.net/dist/fc3/kernel/ burn in a cd, copy to hard drive and install it and do same for madwifi drivers and make sure you are VERY careful in the kernel you choose.

    OR if you have a pen flash drive save it there and transfer it to you fc3 box!

    I would select this one: kernel-2.6.10-1.760_12.rhfc3.at.i686.rpm

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3

    Permission Error

    Hey, so I downloaded the files you suggested and burned them on a CD to transfer over onto my Linux partition. When I open the CD and doubleclick on the kernel file I get an error message that says I can't open the file and I should check the permission. This even happense after I have logged in as root in the terminal and the little key icon is up top. I tried dragging the files from the CD into a folder in my home directory and then opening the permissions tab under properties and changing the settings but that still doesn't work.

    Sorry to keep bugging you but I really want to get Linux working.

    Thanks.

  6. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3

    New Problem

    Hey sorry disregard that last post I figured out how to install that kernel. Madwifi is still not installing i'm getting this error: requires - /boot/vmlinuz-2.6.10-1.760_FC3 in order to install, i'm guessing that means i've the wrong kernel for that version of madwifi?

    Any ideas?

    thanks.

  7. #6
    Linux Newbie
    Join Date
    Feb 2005
    Location
    England
    Posts
    123
    Try getting the source rpm for madwifi and then creating the rpm again.

  8. #7
    Linux Newbie imdeemvp's Avatar
    Join Date
    Sep 2004
    Location
    California
    Posts
    225

    Re: New Problem

    Quote Originally Posted by ned99
    Hey sorry disregard that last post I figured out how to install that kernel. Madwifi is still not installing i'm getting this error: requires - /boot/vmlinuz-2.6.10-1.760_FC3 in order to install, i'm guessing that means i've the wrong kernel for that version of madwifi?

    Any ideas?

    thanks.
    Did you download the dependency according to your kernel? as I suggest in the how-to....because its asking you for it and once installed it will not ask your for dependency.

  9. #8
    Just Joined!
    Join Date
    Mar 2005
    Posts
    1
    i didn't have atrpms.repo so i created a new file in /etc/yum.repos.d and added the following

    [atrpms-stable]
    name=ATrpms for Fedora Core $releasever stable
    baseurl=http://apt.atrpms.net/fedora/$releasever/en/$basearch/at-stable
    enabled=1
    gpgcheck=1

    But when I try to run $>yum list available it says invalid base url for atrpms-stable

    Any help would be much appreciated

  10. #9
    Linux Newbie imdeemvp's Avatar
    Join Date
    Sep 2004
    Location
    California
    Posts
    225
    that is tha correct link as far as i know may be the server was busy or could be a connection problem specially with dial-up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •