Find the answer to your Linux question:
Results 1 to 9 of 9
System specs: Sony Vaio PCG-XG18 Mandrake 10.1 Linux Kernel 2.6.8 D-Link DWL-650 with ADMtek chip. (I checked with D-Link and verified this using the FCC number) Steps taken (in detail): ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    3

    adm8211 installed but nothing working?


    System specs:
    Sony Vaio PCG-XG18
    Mandrake 10.1
    Linux Kernel 2.6.8
    D-Link DWL-650 with ADMtek chip. (I checked with D-Link and verified this using the FCC number)

    Steps taken (in detail):
    1) Downloaded adm8211-20041111.tar.bz2 driver from Sourmilk.
    2) cp the file to /root directory.
    3) bunzip2 and tar -xf the file resulting in adm8211 directory.
    4) installed latest gcc and the entire kernel source from the Mandrake control center using CDs.
    5)Restart machine.
    6) Using Konsole log in as root using su.
    7) drill into /root/adm8211 directory
    type: make install, and everything seems to work properly, no errors. after depmod -a automatically finished i'm back at command line.
    9) HOWEVER, nothing works. I have no activity on the card and trying to configure it has proved unsuccessful.

    I have tried using ifconfig eth0 192.168.x.x to bring it up, didn't work.

    modprobe adm8211 seems to work.
    lsmod shows adm8211 in the list used by 0.

    I'm a newbie at this so any help would be greatly appreciated.

    Btw, I used the 20041111 version of the driver because that is the last one before the author requires the kernel to be at least 2.6.9, with this one only 2.6.6 or later is required.

    What should I check to make sure the make install worked properly?

    I have noticed that when I reboot my machine, lsmod shows that the adm8211 module is NOT in the list. After modprobe adm8211 it shows up again. Why is this?

    Once again, a newbie, but fairly savvy, any help please. I've been working on this for two days before posting but I'm over my head now.
    Thanks
    mepasha

  2. #2
    Just Joined!
    Join Date
    Apr 2005
    Location
    Alamogordo, NM
    Posts
    3

    adm8211 installed but nothing working

    I am having the same problem. but i can't get even as far as you.

    I am running Fedora FC3. You did'nt mention in your post, but did you open the ADM8211 directory and double click on INSTALL? It gives more requiremants and install insrtuctions. I am even more of a newbie than you. I didnt understand a bit of it.

    I get two errors when I try to make. They both have to do with the -hw object. Hope this helps, if so let me know. If you have allready solved the problem, let me know what you did.

    You know, it's a shame. No replys since April 2.

    Calvin

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Location
    Madrid
    Posts
    2

    ADM8211 (Debian)

    Hello all,

    I have a ADM8211 working for a year under Debian with kernel 2.4.20/21/22. I used the official ADM drivers (no GPL).

    By the way, to enable the wireless card it's not enough to bring up the interface with 'ifconfig eth1 ....'; the card must know the ESSID (at least), and it's given by the 'iwconfig' command. If your card is loaded (with modprobe or by putting 'adm8211' in /etc/modules) you will need to run:

    ifconfig eth1 192.168.1.10 netmask 255.255.255.0 ...
    iwconfig eth1 mode Managed
    iwconfig eth1 essid myhomenet

    You can look about the iwconfig man page for set the WEP encription, the channel, and other options.

    There is some info about the ADM8211 on:
    http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/

    And a little howto in
    http://www.linuxhomenetworking.com/l...mp11-linux.htm


    P.D. Now I've moved to kernel 2.6.10 with the GPL drivers and I've a beautiful Kernel Panic with this module. If I could fix it, I will post the tip here.

    Bye

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2005
    Location
    Alamogordo, NM
    Posts
    3

    ADM8211 (Debian)

    Thanks tbarreno,

    I have a copy of Debian here somewhere. Prehaps I will Try it.

    You said you used the "official" ADM drivers. Where did you obtain them? I have never been able to log onto admtek.com.tw I have been trying to use 'adm8211-20041111.tar.bz2' but can never get it 'make install' without errors.

    Thanks for the help.

    Calvin

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Location
    Madrid
    Posts
    2
    Hello Calvin,

    Could you post your compiler error? The driver compiles on my box (then it hangs but at least it compiles ).

    I got the original drivers from the dlink support pages (I remember follow the links to the www.admtek.com.tw site). But I've tried to get it now and it's offline.

    The RPM that contains the 'iwconfig' and others is "wireless-tools", I think it's installed by default.

    Cheers,

  7. #6
    Just Joined!
    Join Date
    Apr 2005
    Location
    Alamogordo, NM
    Posts
    3

    output of make install

    Here is the output I get when I type 'make install'

    make -C /lib/modules/2.6.9-1.667/build M=/ modules
    make[1]: Entering directory `/lib/modules/2.6.9-1.667/build'
    scripts/makefile.build:64: kbuild: Makefile.build is included imroperly
    CC [M] /adm8211_hw.o
    /adm8211_hw.o: In function `adm8211_probe':
    /adm8211_hw.o:2394: warning: ignoring return value of `pci_set_consistent_dma_mask', declared with attribute warn_unsed_result:
    /adm8211_hw.o: In function `adm8211_suspend':
    /adm8211_hw.o:2580: error: too few arguments to function `pci_save_state'
    /adm8211_hw.o: in functin `adm8211_resume':
    /adm8211_hw.o:2589: error: too few arguments to function `pci_restore_state'
    make[2]: *** [/adm8211_hw.o] Error 1
    make[1]: *** [_module_] Error 2
    make[1]: Leaving directory `/lib/modules/2.6.9-1.667/build'
    make: *** [modules] Error 2
    [root@localhost /]#


    some of the above lines may truncate.

    I am using Blitzz wireless adapter. a $49.95 WalMart special.
    I did a 'whois' on admtek.com.tw and it returned "Host not found" so it looks like they are no longer in the DNS.

    Thanks for the help.
    Calvin

    P.S. This is just something I would like to see work. I have a wired NIC that I can put in and run cable <g>.

  8. #7
    Just Joined!
    Join Date
    May 2005
    Posts
    1
    Try a different version of the driver package. I got the exact same errors when I tried to build 20050323 on Fedora 3. I reread the INSTALL file etc.
    and couldn't figure it out, then finally noticed on the Sourmilk download page that the 2.6.10 kernel was required as of the 20041227 package. So I tried the 20041122 package and it built with no errors (the unsed_result warning is there, but it still built). Perhaps 20041111 package is too old for 2.6.9.

    I still don't have the configuration right, but at least it's installed, and doesn't hang on boot like the official ADM driver did when I tried it.

    Good Luck,
    TM

  9. #8
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1

    Extra help?

    Hey guys, I'm a BIG newb to Linux...I've at least sucessfully installed Slackware 10, now I'm trying to figure out how to install the exact same wireless NIC you guys are talking about in this thread. I've got the same "Wal-Mart special" listed above. Can you guys give me some steps (w/any commands) that I'll need to do to get the card going? I've already got the adm8211-20040411.tar.bz2 driver downloaded, but the 'make install' command just gives me errors and I'm not sure what else I need to do...Any help would be appreciated. Rightnow I feel like I'm grabbing at straws, since I just don't know nearly enough yet...

    Thx-
    Greg

  10. #9
    Just Joined! cuervo73's Avatar
    Join Date
    Apr 2006
    Posts
    47

    Re: adm8211 installed but nothing working?

    Hi mepasha,

    The reason that you have to repeat the modprobe after a reboot, is because the information is not saved/cached automatically. But, if you go edit the file /etc/modprobe.conf and add a line:

    alias eth0 adm8211

    and save the file, it will work after a reboot without your manual input.

    cuervo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •