Find the answer to your Linux question:
Results 1 to 8 of 8
In the configuration part of the name server in Yast2, three name servers can be entered. I wonder why? If the first name server is down, there will be no ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    DNS - why only the first DNS server is looked up??


    In the configuration part of the name server in Yast2, three name servers can be entered. I wonder why? If the first name server is down, there will be no second lookup to the second one!! Can anyone explain me why?! Maybe something is wrong in some other settings?!

    Thanks [/b]

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    What do you mean there will be no second to lookup??

    If you put DNS servers from 3 completely different sources, there will.

    What i tend to do is put the 2 from my ISP in the first 2 boxes, then put a public DNS server in the 3rd box, then if my ISP's DNS servers BOTH go down at the same time, i can still get to a DNS.

    Well, SHOULD! the chances of all 3 dns servers goin down are not all that likely
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    I know its somehow crazy and therefore I post it here

    Just tray it out on your own! If the "out of service" DNS Server (in my case 80.120.17.50) is in the first place and the good one (195.3.96.67) in the second place, Konqueror cannot resolve the name ("Unknown host www.suse.de"). Changing the places solved the problem.

    It takes me a long time to came to this one!!! Also using other DNS Servers doesn’t change this strange behaviour. But, as I posted in the first post, maybe there is some other setting influencing this DNS-resolving-mismatch.

  4. #4
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    and u have them in your /etc/resolv.conf like this:

    Code:
    nameserver 80.120.17.50
    nameserver 195.3.96.67
    and switchin the IP's makes it work ok?
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  5. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5

    dns cannot resolve

    Can anyone help me how to setup a DNS on RedHat Enterprise 4 ES. I tried it before using Redhat 9 but I wasn't successful. I need to up www.amellar.net the DNS Server IP is 203.131.71.90 and the Web Server is 203.131.71.93 this is external.

    It always said that "The connection was refused when attempting to contact www.amellar.net I had already disabled my firewalll.

    Can anyone help me please.

  6. #6
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    jporpilla, your ISP should have sent you a couple of DNS Servers to use when you registered. What u need to do is edit the /etc/resolv.conf file (as root and add them like this:

    Code:
    nameserver <ip of DNS 1>
    nameserver <ip of DNS 2>
    but change <ip of DNS1 to the primary DNS server your ISP suppliued you, and the <ip of DNS 2> as the secondary DNS they gave you.

    You can also add a 3rd DNS if you want, just add an extra nameserver line on the bottom, however, 2 DNS should keep you going for a long time
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  7. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5
    Yes, my etc/resolv.conf contains the ff:

    nameserver 203.172.11.21
    nameserver 203.131.71.90
    nameserver 203.131.71.93

    the first nameserver was my ISP DNS that was given to me, the 2nd & 3rd are my DNS Server & Webserver.

    It still says that the connection was refused and still can't find www.amellar.net

  8. #8
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    do you have a secondary DNS from the ISP?

    Try lookin on the net for a public DNS near u and add that in.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •