Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Gettin Linux to recognize a USB wireless adapter?

    Hi. I have a sad laptop - I could go into the details but what's ultimatly happend is that my PCMCIA slot doesn't work, and neither does my ethernet port. This leaves me in a sad situation as far as networking goes.

    I tried using 1394, plugging it into my XP system, but all I recall is that I couldn't get that to work. So I went out and bought one of those USB wireless 802.11 B adapters. What didn't occur to me was that Linux isn't nearly as forgiving as windows when it comes to plug and play devices. I have a power light on the adapter, but Linux seems to give me no indication that it's even installed. I went to network configuration and all it sees are eth0 (my LAN port that doesn't work) and eth1 (my 1394 port). How do I get it to recognize my USB adapter as an eth2? Furthermore, how do I configure it to detect my network SSID and such? Does Mandrake come with such a utility or do I need to install another piece of software?

    Please say no - as I've said there's no networking, the laptop has no CDRom drive. Needless to say, getting files to and from this beast is less than easy - to install Linux I had to take the HD out of the laptop and use an adapter to plug it into my desktop system.


  2. #2
    what happened to that laptop!?

    well heres what i would try goto system>mandrake control center>net and internet>create a new connection>wireless

    and select whatever it is (what is it exactly can you tell us)

    it may or may not need drivers from the cd (yeah i said drivers)

    if thats the case i would copy the files i needed from the cd to the hard disk (the same way you got mandrake on the hd)

    well thats just my suggestion tell us how it goes.

  3. #3
    What happened to the laptop? Well the ethernet port went about a year ago during a lightning storm. At that point I used a linksys wireless card. The hd was also making noises, so I replaced it with one with a Linux install, and in the process managed to screw up the PCMICA connector somehow.

    The card is an SMC2662W. Mandrake didn't come with drivers for it, so I ran a quick google search and found this:

    That doesn't look good - I barley scrape by with my pathetic Linux knowledge as it is... this guy ended up compiling my own drivers, and still didn't get ideal results... :S

    The CD only has drivers for win2k, 98, and XP - that that wouldn't help.

    Any other bright ideas, or is everyone going to direct me to the instructions in the thread I just linked to?

  4. $spacer_open
  5. #4
    i don't know how much help i'll be since i don't have a laptop, wireless, or even that many usb devices.

    but after doing a bit of searching i saw a SMC2662WV2_Linux.tar.gz floating around (couldn't find an actual source to download though)

    but i also noticed that had drivers (and a linux catagory). i couldn't go futher then that becuase i didn't have the product #

    i hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts